Compilation error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Compilation error

Miri Trope
Hi all,

My project's partner installed Slicer3 in 2008. He had added an aditional module which included .xml and .cpp files which worked fine until now.
Today (after two years that nobody have compiled it) I've added one word in the description field in the .xml file and rebuild the solution.
As a result, a lot of errors occurred (even after I've deleted the word) some of them I've fixed, and now my error is as follows:
when I'm trying to build the project, I'm getting the massage:

1>------ Build started: Project: ComputeDistanceMaps, Configuration: Debug Win32 ------
1>Generating ComputeDistanceMapsCLP.h
1>Project : error PRJ0019: A tool returned an error code from "Generating ComputeDistanceMapsCLP.h"
1>Build log was saved at "file://c:\cygwin\home\rubke\Slicer3-build\Applications\CLI\ComputeDistanceMaps\ComputeDistanceMaps.dir\Debug\BuildLog.htm"
1>ComputeDistanceMaps - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========


In addition, Slicer3.exe doesn't open (he try and vanish after one second) ...
What should I do?

Thanks in advance.


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Compilation error

pieper
Administrator
Hi -

Files like ComputeDistanceMapsCLP.h are generated during the build
process - there should be a line in the build that runs GenerateCLP when
the xml changes.  Perhaps this is a permission issue and the file can't
be written?

In terms of your build not starting up correctly, you can set up visual
studio for debugging with the instructions here:

> http://www.slicer.org/slicerWiki/index.php/Slicer3:Build_Instructions#Debugging

-Steve

On 01/27/2011 07:01 PM, Miri Trope wrote:

> Hi all,
>
> My project's partner installed Slicer3 in 2008. He had added an
> aditional module which included .xml and .cpp files which worked fine
> until now.
> Today (after two years that nobody have compiled it) I've added one word
> in the description field in the .xml file and rebuild the solution.
> As a result, a lot of errors occurred (even after I've deleted the word)
> some of them I've fixed, and now my error is as follows:
> when I'm trying to build the project, I'm getting the massage:
>
> 1>------ Build started: Project: ComputeDistanceMaps, Configuration:
> Debug Win32 ------
> 1>Generating ComputeDistanceMapsCLP.h
> 1>Project : error PRJ0019: A tool returned an error code from
> "Generating ComputeDistanceMapsCLP.h"
> 1>Build log was saved at
> "file://c:\cygwin\home\rubke\Slicer3-build\Applications\CLI\ComputeDistanceMaps\ComputeDistanceMaps.dir\Debug\BuildLog.htm"
> 1>ComputeDistanceMaps - 1 error(s), 0 warning(s)
> ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
>
>
> *In addition,* Slicer3.exe doesn't open (he try and vanish after one
> second) ...
> What should I do?
>
> Thanks in advance.
>
>
>
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject