EMSegmenter without Atlas bone segmentation

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

EMSegmenter without Atlas bone segmentation

Marina Bysewski
Hello,

I tried to use the EMSegmenter without Atlas but the result was empty (the label map seems empty, there is no label drawing on the slices). I want to segment different bones from a CT scan, is that possible with that module?
Does anyone have a tutorial for that module?
I think I did something wrong during step 2 or 3. At step 2 i just selected a color table and the right label. At step 3 I selected the label and clicked on the bones I want to segment for manual sampling. The segmentation finishes, but, as I wrote above, there are no labels marked on the slices and when I run the Model Maker with the label map Volume, there is just an empty result.

Thanks for your help.

Greetings from Germany,
Marina Bysewski

PS: I use Slicer version 4.2.2-1
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: EMSegmenter without Atlas bone segmentation

Kilian Pohl
Hi Marianna,

There is currently no tutorial for EMSegmenter without Atlas. Here are a
couple of questions:
- In Step 2:
   - Was any of the labels assigned to Black ( 0 ) ?
   - did you only define a label for the bone ? If so, you also need to
define a background class .
- In Step 3:
   - Did you only take samples for bone ? You have to takes samples for
all labels and at least 10 per label.

If it still does not work do you mind doing the following:
Restart Slicer, go through the steps and just before you hit segment
save the mrml scene . Can you then send me the mrml scene + input image
and I will take a look at it .

Thanks

Kilian

On 5/8/2013 4:31 AM, Marina Bysewski wrote:

> Hello,
>
> I tried to use the EMSegmenter without Atlas but the result was empty (the label map seems empty, there is no label drawing on the slices). I want to segment different bones from a CT scan, is that possible with that module?
> Does anyone have a tutorial for that module?
> I think I did something wrong during step 2 or 3. At step 2 i just selected a color table and the right label. At step 3 I selected the label and clicked on the bones I want to segment for manual sampling. The segmentation finishes, but, as I wrote above, there are no labels marked on the slices and when I run the Model Maker with the label map Volume, there is just an empty result.
>
> Thanks for your help.
>
> Greetings from Germany,
> Marina Bysewski
>
> PS: I use Slicer version 4.2.2-1
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Fwd: EMSegmenter without Atlas bone segmentation

Steve Pieper
Hi - 

I'm forwarding this email along since there have been reports of some email not getting through.  If you have problems getting or sending email on the list let us know and we'll inform the system administrators.

Thanks,
Steve

---------- Forwarded message ----------
From: Kilian Pohl <[hidden email]>
Date: Wed, May 8, 2013 at 12:43 PM
Subject: Re: [slicer-users] EMSegmenter without Atlas bone segmentation
To: [hidden email]


Hi Marianna,

There is currently no tutorial for EMSegmenter without Atlas. Here are a
couple of questions:
- In Step 2:
   - Was any of the labels assigned to Black ( 0 ) ?
   - did you only define a label for the bone ? If so, you also need to
define a background class .
- In Step 3:
   - Did you only take samples for bone ? You have to takes samples for
all labels and at least 10 per label.

If it still does not work do you mind doing the following:
Restart Slicer, go through the steps and just before you hit segment
save the mrml scene . Can you then send me the mrml scene + input image
and I will take a look at it .

Thanks

Kilian

On 5/8/2013 4:31 AM, Marina Bysewski wrote:
> Hello,
>
> I tried to use the EMSegmenter without Atlas but the result was empty (the label map seems empty, there is no label drawing on the slices). I want to segment different bones from a CT scan, is that possible with that module?
> Does anyone have a tutorial for that module?
> I think I did something wrong during step 2 or 3. At step 2 i just selected a color table and the right label. At step 3 I selected the label and clicked on the bones I want to segment for manual sampling. The segmentation finishes, but, as I wrote above, there are no labels marked on the slices and when I run the Model Maker with the label map Volume, there is just an empty result.
>
> Thanks for your help.
>
> Greetings from Germany,
> Marina Bysewski
>
> PS: I use Slicer version 4.2.2-1
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: EMSegmenter without Atlas bone segmentation

Marina Bysewski
In reply to this post by Marina Bysewski
Hi Kilian,

thanks for your tips. I forgot to pick samples for the background label, but unfortunately it still doesn't work.

Here is my scene as you requested.



For testing I used the CTChest example. Thanks for your efforts.

Best,
Marina
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

2013-05-13-Scene.mrml (60K) Download Attachment
AnnotationROI.acsv (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: EMSegmenter without Atlas bone segmentation

Kilian Pohl
Hi Mariana,

Thanks for providing me with all the files (MRML File and files associated with the mrml file).

The problem is that the file you try to segment, called  CTChest.nrrd, has negative values. My pipeline automatically sets voxels with negative values to zero. So here are two things you can do:

Option A) You run the EMSegmenter once. This results in CTChest_pos, which is CTChest with the negative values set to zero. Save the volume , restart Slicer , and run the EMSegmenter again but now with CTChest_pos. Make sure that the samples you take for the background are not all zero. Also be aware that a lot of anatomical detail is lost in CTChest_pos

Option B) you add 3024 to CTChest.nrrd so that all values of the volume are non-negative (-3024 is the lowest values):
- create an image where all the voxels have value 3024:  select Threshold Scalar Volume , Input Volume: CTChest Output Volume: Create New Volume , select Type outside;  set lower, upper , outside value to 3024 -> Press Apply
- Select Add Scalar Volume and add this volume (called Output Volume) to CTChest. Create a new volume for the output volume -> Save the resulting volume which is now CTChest but only with non-negative values
- restart Slicer and try out the EMSEgmenter with that one

Hope it helps

Kilian


On 05/13/2013 06:14 AM, Marina Bysewski wrote:
Hi Kilian,

thanks for your tips. I forgot to pick samples for the background label, but unfortunately it still doesn't work.

Here is my scene as you requested.



For testing I used the CTChest example. Thanks for your efforts.

Best,
Marina


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject