EMSegmenterCommandLine

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

EMSegmenterCommandLine

Agoston Szepessy

Hi,


I'm trying to use EMSegmenterCommandLine in 3D Slicer 4.5 on Ubuntu 14.04 but I get an error each time. The segmentation gets completed correctly, but there are some errors and warnings during the process. The command that I run is:


./Slicer --launch ~/Documents/Slicer-4.5.0-1-linux-amd64/lib/Slicer-4.5/cli-modules/EMSegmentCommandLine --verbose --mrmlSceneFileName ~/Documents/Slicer-4.5.0-1-linux-amd64/share/Slicer-4.5/qt-loadable-modules/EMSegment/Tasks/MRI-Human-Brain.mrml --targetVolumeFileNames ~/Documents/Image.nii --resultVolumeFileName ~/Documents/step2-result.nii


I have attached the error that I get each time I run it along with the Nifti file (compressed so it can fit in the email) that I am using. Is there a way to make those warnings and errors disappear?


Thank you,


Agoston Szepessy


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ

error.log (8K) Download Attachment
Image.nii.zip (9M) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: EMSegmenterCommandLine

Agoston Szepessy

Hi,


I have a correction to make. The segmentation doesn't get completed at all; the file I thought was the segmented one produced by 3D Slicer 4.5 was actually produced by 3D Slicer 3.6. Is there a way to use EMSegmenterCommandLine in 3D Slicer 4.5?


Thank you,


Agoston Szepessy


From: Agoston Szepessy
Sent: June 16, 2016 2:52:03 PM
To: [hidden email]
Subject: EMSegmenterCommandLine
 

Hi,


I'm trying to use EMSegmenterCommandLine in 3D Slicer 4.5 on Ubuntu 14.04 but I get an error each time. The segmentation gets completed correctly, but there are some errors and warnings during the process. The command that I run is:


./Slicer --launch ~/Documents/Slicer-4.5.0-1-linux-amd64/lib/Slicer-4.5/cli-modules/EMSegmentCommandLine --verbose --mrmlSceneFileName ~/Documents/Slicer-4.5.0-1-linux-amd64/share/Slicer-4.5/qt-loadable-modules/EMSegment/Tasks/MRI-Human-Brain.mrml --targetVolumeFileNames ~/Documents/Image.nii --resultVolumeFileName ~/Documents/step2-result.nii


I have attached the error that I get each time I run it along with the Nifti file (compressed so it can fit in the email) that I am using. Is there a way to make those warnings and errors disappear?


Thank you,


Agoston Szepessy


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: EMSegmenterCommandLine

Kilian Pohl
Hi Agoston,

Have you tried the following :
- run cmd by specifying the full path instead of ~
- run cmd from ~/Documents/Slicer-4.5.0-1-linux-amd64/share/Slicer-4.5/qt-loadable-modules/EMSegment/Tasks
- run cmd from ~/Documents/Slicer-4.5.0-1-linux-amd64/lib/Slicer-4.5/cli-modules/

Let me know if that works

Kilian

On 6/16/2016 1:02 PM, Agoston Szepessy wrote:

Hi,


I have a correction to make. The segmentation doesn't get completed at all; the file I thought was the segmented one produced by 3D Slicer 4.5 was actually produced by 3D Slicer 3.6. Is there a way to use EMSegmenterCommandLine in 3D Slicer 4.5?


Thank you,


Agoston Szepessy


From: Agoston Szepessy
Sent: June 16, 2016 2:52:03 PM
To: [hidden email]
Subject: EMSegmenterCommandLine
 

Hi,


I'm trying to use EMSegmenterCommandLine in 3D Slicer 4.5 on Ubuntu 14.04 but I get an error each time. The segmentation gets completed correctly, but there are some errors and warnings during the process. The command that I run is:


./Slicer --launch ~/Documents/Slicer-4.5.0-1-linux-amd64/lib/Slicer-4.5/cli-modules/EMSegmentCommandLine --verbose --mrmlSceneFileName ~/Documents/Slicer-4.5.0-1-linux-amd64/share/Slicer-4.5/qt-loadable-modules/EMSegment/Tasks/MRI-Human-Brain.mrml --targetVolumeFileNames ~/Documents/Image.nii --resultVolumeFileName ~/Documents/step2-result.nii


I have attached the error that I get each time I run it along with the Nifti file (compressed so it can fit in the email) that I am using. Is there a way to make those warnings and errors disappear?


Thank you,


Agoston Szepessy



_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: EMSegmenterCommandLine

Agoston Szepessy
In reply to this post by Agoston Szepessy

Hi Kilian,

It works now. I must have mistyped something because I can run it from my home directory,by either specifying the full path or just ~.

Thank you for your help.

Agoston


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ