Fwd: Problem with Editor in 3.6.1

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: Problem with Editor in 3.6.1

Andrey Fedorov
---------- Forwarded message ----------
From: Christoph Ammann <[hidden email]>
Date: Tue, Sep 14, 2010 at 14:38
Subject: Re: Registration code and logistics issues
To: Hatsuho Mamata <[hidden email]>, [hidden email],
Andriy Fedorov <[hidden email]>


Hi,

I went through the suggested tutorials but I am having trouble with
slide 35 of 61 of the Interactive Editor Tutorial. I followed the
tutorial step-by-step but everytime I click on the draw tool I get the
following message (see screenshot):
can't read "dir(plane,A)": no such element in array

I installed Slicer 3.6.1 by following the build instructions on:
http://www.slicer.org/slicerWiki/index.php/Slicer3:Build_Instructions

After I saw the message above, I ran
./Slicer3/Scripts/getbuildtest.tcl
again, hoping that this would update my installation of Slicer (I
installed Slicer just yesterday) and possibly solve my problem. Turns
out, that this didn't solve my problem. The problem persists and is
reproducible on the lab computer simply by clicking on the icon of the
draw tool (I will check the installation on my laptop later this day).

Do you guys have the same problem? Did you install Slicer also by
following the build instructions or did you download & install a
binary release from slicer.org?
I will forward this email to the slicer-users-mailing-list later this day.

Thank you,
Christoph

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

draw_tool.png (541K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: Problem with Editor in 3.6.1

swallace
Hi Christoph-

I will take a look into this for you.  

I've had no issues with the editor module on any of the stable versions or previous instances. Which version did you checkout?

Sent from my Verizon Wireless BlackBerry

-----Original Message-----
From: Andriy Fedorov <[hidden email]>
Date: Tue, 14 Sep 2010 16:58:27
To: <[hidden email]>
Cc: Stuart Wallace<[hidden email]>; Christoph Ammann<[hidden email]>
Subject: Fwd: Problem with Editor in 3.6.1

---------- Forwarded message ----------
From: Christoph Ammann <[hidden email]>
Date: Tue, Sep 14, 2010 at 14:38
Subject: Re: Registration code and logistics issues
To: Hatsuho Mamata <[hidden email]>, [hidden email],
Andriy Fedorov <[hidden email]>


Hi,

I went through the suggested tutorials but I am having trouble with
slide 35 of 61 of the Interactive Editor Tutorial. I followed the
tutorial step-by-step but everytime I click on the draw tool I get the
following message (see screenshot):
can't read "dir(plane,A)": no such element in array

I installed Slicer 3.6.1 by following the build instructions on:
http://www.slicer.org/slicerWiki/index.php/Slicer3:Build_Instructions

After I saw the message above, I ran
./Slicer3/Scripts/getbuildtest.tcl
again, hoping that this would update my installation of Slicer (I
installed Slicer just yesterday) and possibly solve my problem. Turns
out, that this didn't solve my problem. The problem persists and is
reproducible on the lab computer simply by clicking on the icon of the
draw tool (I will check the installation on my laptop later this day).

Do you guys have the same problem? Did you install Slicer also by
following the build instructions or did you download & install a
binary release from slicer.org?
I will forward this email to the slicer-users-mailing-list later this day.

Thank you,
Christoph

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: Problem with Editor in 3.6.1

Junichi Tokuda
In reply to this post by Andrey Fedorov
Dear Slicer developers,

Andriy, Christoph and I looked into the issue and found that the recent
bug fix (after 3.6.1 release) in Slicer3/Modules/Editor may cause this issue.
We didn't see the trouble when we use revision 14658 of Slicer3/Modules/Editor directory.

-Junichi


On Sep 14, 2010, at 4:58 PM, Andriy Fedorov wrote:

> ---------- Forwarded message ----------
> From: Christoph Ammann <[hidden email]>
> Date: Tue, Sep 14, 2010 at 14:38
> Subject: Re: Registration code and logistics issues
> To: Hatsuho Mamata <[hidden email]>, [hidden email],
> Andriy Fedorov <[hidden email]>
>
>
> Hi,
>
> I went through the suggested tutorials but I am having trouble with
> slide 35 of 61 of the Interactive Editor Tutorial. I followed the
> tutorial step-by-step but everytime I click on the draw tool I get the
> following message (see screenshot):
> can't read "dir(plane,A)": no such element in array
>
> I installed Slicer 3.6.1 by following the build instructions on:
> http://www.slicer.org/slicerWiki/index.php/Slicer3:Build_Instructions
>
> After I saw the message above, I ran
> ./Slicer3/Scripts/getbuildtest.tcl
> again, hoping that this would update my installation of Slicer (I
> installed Slicer just yesterday) and possibly solve my problem. Turns
> out, that this didn't solve my problem. The problem persists and is
> reproducible on the lab computer simply by clicking on the icon of the
> draw tool (I will check the installation on my laptop later this day).
>
> Do you guys have the same problem? Did you install Slicer also by
> following the build instructions or did you download & install a
> binary release from slicer.org?
> I will forward this email to the slicer-users-mailing-list later this day.
>
> Thank you,
> Christoph
> <draw_tool.png>_______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: Problem with Editor in 3.6.1

pieper
Administrator
Sorry for the difficulties - I backed out the change to the editor so if
you rebuild now from the Slicer-3-6 release branch things should be back
to normal.

-Steve

On Sep/15/10 12:08 AM, Junichi Tokuda wrote:

> Dear Slicer developers,
>
> Andriy, Christoph and I looked into the issue and found that the recent
> bug fix (after 3.6.1 release) in Slicer3/Modules/Editor may cause this issue.
> We didn't see the trouble when we use revision 14658 of Slicer3/Modules/Editor directory.
>
> -Junichi
>
>
> On Sep 14, 2010, at 4:58 PM, Andriy Fedorov wrote:
>
>> ---------- Forwarded message ----------
>> From: Christoph Ammann<[hidden email]>
>> Date: Tue, Sep 14, 2010 at 14:38
>> Subject: Re: Registration code and logistics issues
>> To: Hatsuho Mamata<[hidden email]>, [hidden email],
>> Andriy Fedorov<[hidden email]>
>>
>>
>> Hi,
>>
>> I went through the suggested tutorials but I am having trouble with
>> slide 35 of 61 of the Interactive Editor Tutorial. I followed the
>> tutorial step-by-step but everytime I click on the draw tool I get the
>> following message (see screenshot):
>> can't read "dir(plane,A)": no such element in array
>>
>> I installed Slicer 3.6.1 by following the build instructions on:
>> http://www.slicer.org/slicerWiki/index.php/Slicer3:Build_Instructions
>>
>> After I saw the message above, I ran
>> ./Slicer3/Scripts/getbuildtest.tcl
>> again, hoping that this would update my installation of Slicer (I
>> installed Slicer just yesterday) and possibly solve my problem. Turns
>> out, that this didn't solve my problem. The problem persists and is
>> reproducible on the lab computer simply by clicking on the icon of the
>> draw tool (I will check the installation on my laptop later this day).
>>
>> Do you guys have the same problem? Did you install Slicer also by
>> following the build instructions or did you download&  install a
>> binary release from slicer.org?
>> I will forward this email to the slicer-users-mailing-list later this day.
>>
>> Thank you,
>> Christoph
>> <draw_tool.png>_______________________________________________
>> slicer-users mailing list
>> [hidden email]
>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
>
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject