HelloWorld tutorial image not displayed in Slicer 3

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

HelloWorld tutorial image not displayed in Slicer 3

Kristen Zygmunt
Hello!
     I recently worked through the Hello World tutorial for creating a  
command-line module.  This worked great except that the resulting  
image was not displayed in Slicer as the tutorial said it would be.  I  
saw some output in the terminal window that told me where the  
resulting image was written to and was then able to Add Volume... to  
open and view the image and see that it was indeed filtered.  I didn't  
see anything obvious in the code I edited, so I found the HelloSlicer  
module in Modules/CommandLineModule/Testing/HelloSlicer and built this  
module.  The same behavior occurred using that module as well -- image  
was filtered and written to file, but not displayed.

Has something changed in Slicer 3 where there needs to be additional  
code added to the command-line module to support display of the output  
image?

-Kris Z.
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: HelloWorld tutorial image not displayed in Slicer 3

swallace
Currently working through this tutorial Kris; happy to help troubleshoot
for you.

Which Slicer version are you using, and on what platform?


Stuart


> Hello!
>      I recently worked through the Hello World tutorial for creating a
> command-line module.  This worked great except that the resulting
> image was not displayed in Slicer as the tutorial said it would be.  I
> saw some output in the terminal window that told me where the
> resulting image was written to and was then able to Add Volume... to
> open and view the image and see that it was indeed filtered.  I didn't
> see anything obvious in the code I edited, so I found the HelloSlicer
> module in Modules/CommandLineModule/Testing/HelloSlicer and built this
> module.  The same behavior occurred using that module as well -- image
> was filtered and written to file, but not displayed.
>
> Has something changed in Slicer 3 where there needs to be additional
> code added to the command-line module to support display of the output
> image?
>
> -Kris Z.
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to
> [hidden email] with unsubscribe as the
> subject
>
>
>

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject