Image stacks in Slicer -other issues

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Image stacks in Slicer -other issues

Murat Maga

I don’t know whether this is related to the rendering issue, but I am having another problems.

 

General registration (BRAINS) module does not display any volume to choose from. Just says “None”. Likewise editor thinks there is no dataset to edit. I have two image stacks already loaded. So somehow those image stacks are not recognized as volumes.

 

M

 

 

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Image stacks in Slicer -other issues

inorton
i'm pretty sure both issues you just emailed about are due to the node type - you are loading stacks of jpegs/tifs right? check the node type in the data module. if it is "VectorVolumeNode" then it won't work with the editor or volume rendering. I would suggest using imagej to load the stack and save as nrrd.

 

On Fri, May 4, 2012 at 1:04 PM, Murat Maga <[hidden email]> wrote:

I don’t know whether this is related to the rendering issue, but I am having another problems.

 

General registration (BRAINS) module does not display any volume to choose from. Just says “None”. Likewise editor thinks there is no dataset to edit. I have two image stacks already loaded. So somehow those image stacks are not recognized as volumes.

 

M

 

 

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Image stacks in Slicer -other issues

Steve Pieper
Hi Murat - 

Isaiah is right, the issue is that most photo formats (jpg, png, bmp...) load as rgb even if the subject matter is grayscale.

I made a Modules->Converters->Vector to Scalar Volume module [1] but didn't check it in at the time because of the impending 4.1 release.  Now that things have stabilized I checked in the module so it will be part of the nightly builds as of tomorrow.  If you can't wait, the instructions in the previous email will still work.

-Steve


On Fri, May 4, 2012 at 1:21 PM, Isaiah Norton <[hidden email]> wrote:
i'm pretty sure both issues you just emailed about are due to the node type - you are loading stacks of jpegs/tifs right? check the node type in the data module. if it is "VectorVolumeNode" then it won't work with the editor or volume rendering. I would suggest using imagej to load the stack and save as nrrd.

 

On Fri, May 4, 2012 at 1:04 PM, Murat Maga <[hidden email]> wrote:

I don’t know whether this is related to the rendering issue, but I am having another problems.

 

General registration (BRAINS) module does not display any volume to choose from. Just says “None”. Likewise editor thinks there is no dataset to edit. I have two image stacks already loaded. So somehow those image stacks are not recognized as volumes.

 

M

 

 

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Image stacks in Slicer -other issues

Murat Maga

Thanks for the answers.

Is it possible to do this during the data load? Perhaps there can be an option to load them as scalar, and a choice of whether it is RGB or 8 bit grayscale?

 

M

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Steve Pieper
Sent: Friday, May 04, 2012 11:18 AM
To: Isaiah Norton
Cc: [hidden email]
Subject: Re: [slicer-users] Image stacks in Slicer -other issues

 

Hi Murat - 

 

Isaiah is right, the issue is that most photo formats (jpg, png, bmp...) load as rgb even if the subject matter is grayscale.

 

I made a Modules->Converters->Vector to Scalar Volume module [1] but didn't check it in at the time because of the impending 4.1 release.  Now that things have stabilized I checked in the module so it will be part of the nightly builds as of tomorrow.  If you can't wait, the instructions in the previous email will still work.

 

-Steve

 

On Fri, May 4, 2012 at 1:21 PM, Isaiah Norton <[hidden email]> wrote:

i'm pretty sure both issues you just emailed about are due to the node type - you are loading stacks of jpegs/tifs right? check the node type in the data module. if it is "VectorVolumeNode" then it won't work with the editor or volume rendering. I would suggest using imagej to load the stack and save as nrrd.


 

 

On Fri, May 4, 2012 at 1:04 PM, Murat Maga <[hidden email]> wrote:

I don’t know whether this is related to the rendering issue, but I am having another problems.

 

General registration (BRAINS) module does not display any volume to choose from. Just says “None”. Likewise editor thinks there is no dataset to edit. I have two image stacks already loaded. So somehow those image stacks are not recognized as volumes.

 

M

 

 

 

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 



_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Image stacks in Slicer -other issues

Julien Finet
http://na-mic.org/Mantis/view.php?id=1984 

On Fri, May 4, 2012 at 2:31 PM, Murat Maga <[hidden email]> wrote:

Thanks for the answers.

Is it possible to do this during the data load? Perhaps there can be an option to load them as scalar, and a choice of whether it is RGB or 8 bit grayscale?

 

M

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Steve Pieper
Sent: Friday, May 04, 2012 11:18 AM
To: Isaiah Norton
Cc: [hidden email]
Subject: Re: [slicer-users] Image stacks in Slicer -other issues

 

Hi Murat - 

 

Isaiah is right, the issue is that most photo formats (jpg, png, bmp...) load as rgb even if the subject matter is grayscale.

 

I made a Modules->Converters->Vector to Scalar Volume module [1] but didn't check it in at the time because of the impending 4.1 release.  Now that things have stabilized I checked in the module so it will be part of the nightly builds as of tomorrow.  If you can't wait, the instructions in the previous email will still work.

 

-Steve

 

On Fri, May 4, 2012 at 1:21 PM, Isaiah Norton <[hidden email]> wrote:

i'm pretty sure both issues you just emailed about are due to the node type - you are loading stacks of jpegs/tifs right? check the node type in the data module. if it is "VectorVolumeNode" then it won't work with the editor or volume rendering. I would suggest using imagej to load the stack and save as nrrd.


 

 

On Fri, May 4, 2012 at 1:04 PM, Murat Maga <[hidden email]> wrote:

I don’t know whether this is related to the rendering issue, but I am having another problems.

 

General registration (BRAINS) module does not display any volume to choose from. Just says “None”. Likewise editor thinks there is no dataset to edit. I have two image stacks already loaded. So somehow those image stacks are not recognized as volumes.

 

M

 

 

 

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 



_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject