Slicer Build Instructions problem

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Slicer Build Instructions problem

Hans
Hi everybody!

I'm completely new at Slicer. I want to make a slicer module. For this, I started with the "Build instructions" chapter from the slicer Wiki (http://wiki.slicer.org/slicerWiki/index.php/Documentation/4.1/Developers/Build_Instructions).
My problem is, that I don't get a runnable file. I should have the two new directory Slicer4-Superbuild and Slicer4-Superbuild/Slicer-build after the "CONFIGURE and generate Slicer solution files" step . But I just have the Slicer4-SuperBuild-Debug directory (/home/hans/work/Slicer/Slicer4-SuperBuild-Debug). The datas from the SVN are in the directory: /home/hans/work/Slicer/Slicer. I used the Ubuntu search function but couldn't find the folders. Thats the first strange thing.
For the next step, I started to build slicer, with the make command, in the Slicer4-SuperBuild-Debug directory. That worked, but I don't get a runnable slicer file. So, I guess the problem is somewhere in the "CONFIGURE and generate Slicer solution files" step.
I'm using Ubuntu 11.10, Slicer version is 4.1.0, the Qt SDK is version 1.22.
I hope my question is not too confusing(my English is not the best).

Best regards
Hans




Reply | Threaded
Open this post in threaded view
|

Re: Slicer Build Instructions problem

Sharp, Gregory C.

Hi Hans,

Just a note, there is an inconsistency in the wiki;
if your build directory is Slicer4-SuperBuild-Debug, then
the Slicer executable goes into Slicer4-SuperBuild-Debug/Slicer-build
instead of Slicer4-SuperBuild/Slicer-build.

If the above is not your problem, can you please paste the bottom few
lines that are printed to the console when you run "make" in
Slicer4-SuperBuild-Debug?

-Greg


-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Hans
Sent: Monday, January 28, 2013 9:51 AM
To: [hidden email]
Subject: [slicer-users] Slicer Build Instructions problem

Hi everybody!

I'm completely new at Slicer. I want to make a slicer module. For this, I
started with the "Build instructions" chapter from the slicer Wiki
(http://wiki.slicer.org/slicerWiki/index.php/Documentation/4.1/Developers/Build_Instructions).
My problem is, that I don't get a runnable file. I should have the two new
directory Slicer4-Superbuild and Slicer4-Superbuild/Slicer-build after the
"CONFIGURE and generate Slicer solution files" step . But I just have the
Slicer4-SuperBuild-Debug directory
(/home/hans/work/Slicer/Slicer4-SuperBuild-Debug). The datas from the SVN
are in the directory: /home/hans/work/Slicer/Slicer. I used the Ubuntu
search function but couldn't find the folders. Thats the first strange
thing.
For the next step, I started to build slicer, with the make command, in the
Slicer4-SuperBuild-Debug directory. That worked, but I don't get a runnable
slicer file. So, I guess the problem is somewhere in the "CONFIGURE and
generate Slicer solution files" step.
I'm using Ubuntu 11.10, Slicer version is 4.1.0, the Qt SDK is version 1.22.
I hope my question is not too confusing(my English is not the best).

Best regards
Hans








--
View this message in context: http://slicer-users.65878.n3.nabble.com/Slicer-Build-Instructions-problem-tp4025765.html
Sent from the slicer-users mailing list archive at Nabble.com.
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer Build Instructions problem

Jean-Christophe Fillion-Robin
Welcome Hans :) 
Please note the discussion has been moved to the developer list. If you are not yet registered, please do so: http://massmail.bwh.harvard.edu/mailman/listinfo/slicer-devel
Thanks
Jc


On Mon, Jan 28, 2013 at 10:19 AM, Sharp, Gregory C. <[hidden email]> wrote:

Hi Hans,

Just a note, there is an inconsistency in the wiki;
if your build directory is Slicer4-SuperBuild-Debug, then
the Slicer executable goes into Slicer4-SuperBuild-Debug/Slicer-build
instead of Slicer4-SuperBuild/Slicer-build.

If the above is not your problem, can you please paste the bottom few
lines that are printed to the console when you run "make" in
Slicer4-SuperBuild-Debug?

-Greg


-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Hans
Sent: Monday, January 28, 2013 9:51 AM
To: [hidden email]
Subject: [slicer-users] Slicer Build Instructions problem

Hi everybody!

I'm completely new at Slicer. I want to make a slicer module. For this, I
started with the "Build instructions" chapter from the slicer Wiki
(http://wiki.slicer.org/slicerWiki/index.php/Documentation/4.1/Developers/Build_Instructions).
My problem is, that I don't get a runnable file. I should have the two new
directory Slicer4-Superbuild and Slicer4-Superbuild/Slicer-build after the
"CONFIGURE and generate Slicer solution files" step . But I just have the
Slicer4-SuperBuild-Debug directory
(/home/hans/work/Slicer/Slicer4-SuperBuild-Debug). The datas from the SVN
are in the directory: /home/hans/work/Slicer/Slicer. I used the Ubuntu
search function but couldn't find the folders. Thats the first strange
thing.
For the next step, I started to build slicer, with the make command, in the
Slicer4-SuperBuild-Debug directory. That worked, but I don't get a runnable
slicer file. So, I guess the problem is somewhere in the "CONFIGURE and
generate Slicer solution files" step.
I'm using Ubuntu 11.10, Slicer version is 4.1.0, the Qt SDK is version 1.22.
I hope my question is not too confusing(my English is not the best).

Best regards
Hans








--
View this message in context: http://slicer-users.65878.n3.nabble.com/Slicer-Build-Instructions-problem-tp4025765.html
Sent from the slicer-users mailing list archive at Nabble.com.
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--
+1 919 869 8849

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer Build Instructions problem

Hans
In reply to this post by Sharp, Gregory C.
Hey!

Thanks for your answer. Here the error message after the complete make process, I hope it's the right part:

-- Configuring incomplete, errors occurred!
make[5]: *** [CTK-Configure-prefix/src/CTK-Configure-stamp/CTK-Configure-configure] Error 1
make[4]: *** [CMakeFiles/CTK-Configure.dir/all] Error 2
make[3]: *** [all] Error 2
make[2]: *** [CTK-prefix/src/CTK-stamp/CTK-build] Error 2
make[1]: *** [CMakeFiles/CTK.dir/all] Error 2
make: *** [all] Error 2

The Slicer-build directory is empty after the build process...
I tried the same steps on an other computer and  had the same problem. So I guess I'm doing something wrong ;)

best regards
Hans
Reply | Threaded
Open this post in threaded view
|

Re: Slicer Build Instructions problem

Hans
This post has NOT been accepted by the mailing list yet.
In reply to this post by Hans
Hi!

My problem is more or less solved. I just started the make process a second time after the error message and it works now. Hopefully the process is now running to the end without any errors  ;).
I'm anyway thankful for the fast support of this site. I'm sure I'll have many other problems with slicer in the next weeks...

best regards
Hans