Slicer on Linux 64-bit

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Slicer on Linux 64-bit

Wiefek, Jasmin
Hello,
 
I tried to build Slicer 3.4 and Slicer 3.5 on a Linux 64-bit but the program
crashes everytime I try to start it.
May anybody could help?
 
Thanks,
 
Jasmin
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer on Linux 64-bit

pieper
Administrator
Hi Jasmin -

Have a look at this section:

http://www.slicer.org/slicerWiki/index.php/Slicer3:Build_Instructions#Errors_from_getbuildtest

If you can't figure it out from there, post the build log so we can have
a look.

-Steve

Wiefek, Jasmin wrote:

> Hello,
>  
> I tried to build Slicer 3.4 and Slicer 3.5 on a Linux 64-bit but the program
> crashes everytime I try to start it.
> May anybody could help?
>  
> Thanks,
>  
> Jasmin
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer on Linux 64-bit

Mathieu Malaterre
In reply to this post by Wiefek, Jasmin
There is an easy to install package for debian/ubuntu system at:

http://packages.qa.debian.org/s/slicer.html

HTH

On Thu, Dec 10, 2009 at 1:29 PM, Wiefek, Jasmin
<[hidden email]> wrote:

> Hello,
>
> I tried to build Slicer 3.4 and Slicer 3.5 on a Linux 64-bit but the program
> crashes everytime I try to start it.
> May anybody could help?
>
> Thanks,
>
> Jasmin
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
>



--
Mathieu
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer on Linux 64-bit

Sharp, Gregory C.
On Thu, 10 Dec 2009 15:24:59 +0100
Mathieu Malaterre <[hidden email]> wrote:

> There is an easy to install package for debian/ubuntu system at:
>
> http://packages.qa.debian.org/s/slicer.html
>

Wow, that's really cool.

Can we build plugins against the debian Slicer package?

-Greg
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer on Linux 64-bit

Körte, Inga Dr.med.
In reply to this post by Wiefek, Jasmin
Hi,

I am also having trouble with the most recent versions for windows.
After the installation process is completed slicer doesn't start.

Any suggestions?
Thanks, Inga

-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Wiefek, Jasmin
Gesendet: Donnerstag, 10. Dezember 2009 07:29
An: [hidden email]
Betreff: [slicer-users] Slicer on Linux 64-bit

Hello,
 
I tried to build Slicer 3.4 and Slicer 3.5 on a Linux 64-bit but the program
crashes everytime I try to start it.
May anybody could help?
 
Thanks,
 
Jasmin
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer on Linux 64-bit

pieper
Administrator
Hi Inga -

If you are getting an 'invalid agrument' error or something similar when
installing the binary versions of slicer for windows, you may be able to
fix it by following the instructions here:

http://n3.nabble.com/slicer-in-windows-xp-32bit-tt72886.html#a72886

We just discovered the cause of this issue and will hopefully have a fix
for the binaries in the next few days.

-Steve

Körte wrote:

> Hi,
>
> I am also having trouble with the most recent versions for windows.
> After the installation process is completed slicer doesn't start.
>
> Any suggestions?
> Thanks, Inga
>
> -----Ursprüngliche Nachricht-----
> Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Wiefek, Jasmin
> Gesendet: Donnerstag, 10. Dezember 2009 07:29
> An: [hidden email]
> Betreff: [slicer-users] Slicer on Linux 64-bit
>
> Hello,
>  
> I tried to build Slicer 3.4 and Slicer 3.5 on a Linux 64-bit but the program
> crashes everytime I try to start it.
> May anybody could help?
>  
> Thanks,
>  
> Jasmin
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer on Linux 64-bit

Andrey Fedorov
Steve,

I looked and tried to help Inga. There are no error messages at all.
Initial Slicer startup splash screen (without logo) pops up and
disappears, this is it.

Also, as I described in an earlier email, the installation process
behaves strangely. It suddenly stops when the progress bar is around
50% completion, and reports successful installation.

I thought this might be caused by insufficient disk space, but we
confirmed this is not the issue (9GB free).

AF




On Thu, Dec 10, 2009 at 13:08, Steve Pieper <[hidden email]> wrote:

> Hi Inga -
>
> If you are getting an 'invalid agrument' error or something similar when
> installing the binary versions of slicer for windows, you may be able to
> fix it by following the instructions here:
>
> http://n3.nabble.com/slicer-in-windows-xp-32bit-tt72886.html#a72886
>
> We just discovered the cause of this issue and will hopefully have a fix
> for the binaries in the next few days.
>
> -Steve
>
> Körte wrote:
>> Hi,
>>
>> I am also having trouble with the most recent versions for windows.
>> After the installation process is completed slicer doesn't start.
>>
>> Any suggestions?
>> Thanks, Inga
>>
>> -----Ursprüngliche Nachricht-----
>> Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Wiefek, Jasmin
>> Gesendet: Donnerstag, 10. Dezember 2009 07:29
>> An: [hidden email]
>> Betreff: [slicer-users] Slicer on Linux 64-bit
>>
>> Hello,
>>
>> I tried to build Slicer 3.4 and Slicer 3.5 on a Linux 64-bit but the program
>> crashes everytime I try to start it.
>> May anybody could help?
>>
>> Thanks,
>>
>> Jasmin
>> _______________________________________________
>> slicer-users mailing list
>> [hidden email]
>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
>> _______________________________________________
>> slicer-users mailing list
>> [hidden email]
>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
>
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer on Linux 64-bit

madanrao
Hello Andriy,

You can identify the problem by using ProcessMonitor (Procmon.exe):

http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

I would try and do the same today if I need to.

AM Mohan Rao

On Thu, Dec 10, 2009 at 11:55 PM, Andriy Fedorov <[hidden email]> wrote:
Steve,

I looked and tried to help Inga. There are no error messages at all.
Initial Slicer startup splash screen (without logo) pops up and
disappears, this is it.

Also, as I described in an earlier email, the installation process
behaves strangely. It suddenly stops when the progress bar is around
50% completion, and reports successful installation.

I thought this might be caused by insufficient disk space, but we
confirmed this is not the issue (9GB free).

AF




On Thu, Dec 10, 2009 at 13:08, Steve Pieper <[hidden email]> wrote:
> Hi Inga -
>
> If you are getting an 'invalid agrument' error or something similar when
> installing the binary versions of slicer for windows, you may be able to
> fix it by following the instructions here:
>
> http://n3.nabble.com/slicer-in-windows-xp-32bit-tt72886.html#a72886
>
> We just discovered the cause of this issue and will hopefully have a fix
> for the binaries in the next few days.
>
> -Steve
>
> Körte wrote:
>> Hi,
>>
>> I am also having trouble with the most recent versions for windows.
>> After the installation process is completed slicer doesn't start.
>>
>> Any suggestions?
>> Thanks, Inga
>>
>> -----Ursprüngliche Nachricht-----
>> Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Wiefek, Jasmin
>> Gesendet: Donnerstag, 10. Dezember 2009 07:29
>> An: [hidden email]
>> Betreff: [slicer-users] Slicer on Linux 64-bit
>>
>> Hello,
>>
>> I tried to build Slicer 3.4 and Slicer 3.5 on a Linux 64-bit but the program
>> crashes everytime I try to start it.
>> May anybody could help?
>>
>> Thanks,
>>
>> Jasmin
>> _______________________________________________
>> slicer-users mailing list
>> [hidden email]
>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
>> _______________________________________________
>> slicer-users mailing list
>> [hidden email]
>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
>
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slicer on Linux 64-bit

Dave Welch
In reply to this post by pieper
Hi all,

I'm having a viewing problem running Ubuntu Jaunty on a 64-bit eMachines E627.  When I bring up the GUI, the 3D viewer and the two left-most slice viewers are entirely white!  When I mouse over the slice views, they show black with the slice information.  The "green" view (default coronal) is black and when scrolling over, the slice info text appears to have higher-res than the other two views.  (When a volume is loaded, the volume res appears the same.)  The 3D view will not display unless I am using a mouse button on it.  Once I release the button, the view goes white again.  

I've tested this with and without volumes, and the behavior is the same.  Any ideas?

Thank you,
Dave Welch

GUI view
David Welch
University of Iowa
Reply | Threaded
Open this post in threaded view
|

Re: [slicer-users] Slicer on Linux 64-bit

Luke Bloy
Hi Dave,

My guess is that this is a combination of your video drivers and using
compiz.
If you turn off compiz my guess is that it will work.

System->Preferences->Appearance->VisualEffects tab
click on none.

-Luke

Dave Welch wrote:

> Hi all,
>
> I'm having a viewing problem running Ubuntu Jaunty on a 64-bit eMachines
> E627.  When I bring up the GUI, the 3D viewer and the two left-most slice
> viewers are entirely white!  When I mouse over the slice views, they show
> black with the slice information.  The "green" view (default coronal) is
> black and when scrolling over, the slice info text appears to have
> higher-res than the other two views.  (When a volume is loaded, the volume
> res appears the same.)  The 3D view will not display unless I am using a
> mouse button on it.  Once I release the button, the view goes white again.  
>
> I've tested this with and without volumes, and the behavior is the same.
> Any ideas?:confused:
>
> Thank you,
> Dave Welch
>  
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: [slicer-users] Slicer on Linux 64-bit

Dave Welch
Yep, that did it!  Thanks so much!

On Wed, Jan 20, 2010 at 11:53 AM, Luke Bloy <[hidden email]> wrote:
Hi Dave,

My guess is that this is a combination of your video drivers and using compiz.
If you turn off compiz my guess is that it will work.

System->Preferences->Appearance->VisualEffects tab
click on none.

-Luke


Dave Welch wrote:
Hi all,

I'm having a viewing problem running Ubuntu Jaunty on a 64-bit eMachines
E627.  When I bring up the GUI, the 3D viewer and the two left-most slice
viewers are entirely white!  When I mouse over the slice views, they show
black with the slice information.  The "green" view (default coronal) is
black and when scrolling over, the slice info text appears to have
higher-res than the other two views.  (When a volume is loaded, the volume
res appears the same.)  The 3D view will not display unless I am using a
mouse button on it.  Once I release the button, the view goes white again.  
I've tested this with and without volumes, and the behavior is the same. Any ideas?:confused:

Thank you, Dave Welch
 



--
David Welch
Graduate Student
Dept. of Biomedical Engineering
University of Iowa
Lab: (319) 335-5279

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
David Welch
University of Iowa