Slicer slow/laggy on older (hospital) workstations?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Slicer slow/laggy on older (hospital) workstations?

adalca
Hello,

I'm trying to run Slicer on Thinkpad C30 workstations. These run Windows 7
SP1, on Dual Core Xeon E5-2620 2Ghz, 12 Gb ram, NVIDIA Quadro 600 4Gb. They
run several image viewers quite smoothly (including the hospital-supplied
IMPAX viewer).

When I install the latest stable Slicer -- 4.6.2, it's painfully slow to
even scroll through the slices of a normal volume. Changing a slice via the
scroll bar or the mousewheel takes about 2-3 seconds to respond. Is this to
be expected given the configuration of these machines?

I'm trying to understand what I'm doing wrong, or whether these machines
just can't run slicer smoothly. I hope it's not the latter :)

Thanks,
- Adrian



--
View this message in context: http://slicer-users.65878.n3.nabble.com/Slicer-slow-laggy-on-older-hospital-workstations-tp4031749.html
Sent from the slicer-users mailing list archive at Nabble.com.
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: Slicer slow/laggy on older (hospital) workstations?

Andras Lasso-2
2-3 seconds is definitely not normal, even on such an old computer. Try the latest nightly build. Also, check what is reported by Performance tests module (restart Slicer, go to Performance Tests module, click on "Reslicing").

Andras

-----Original Message-----
From: slicer-users [mailto:[hidden email]] On Behalf Of adalca
Sent: February 13, 2017 14:43
To: SPL Slicer Users <[hidden email]>
Subject: [slicer-users] Slicer slow/laggy on older (hospital) workstations?

Hello,

I'm trying to run Slicer on Thinkpad C30 workstations. These run Windows 7 SP1, on Dual Core Xeon E5-2620 2Ghz, 12 Gb ram, NVIDIA Quadro 600 4Gb. They run several image viewers quite smoothly (including the hospital-supplied IMPAX viewer).

When I install the latest stable Slicer -- 4.6.2, it's painfully slow to even scroll through the slices of a normal volume. Changing a slice via the scroll bar or the mousewheel takes about 2-3 seconds to respond. Is this to be expected given the configuration of these machines?

I'm trying to understand what I'm doing wrong, or whether these machines just can't run slicer smoothly. I hope it's not the latter :)

Thanks,
- Adrian



--
View this message in context: http://slicer-users.65878.n3.nabble.com/Slicer-slow-laggy-on-older-hospital-workstations-tp4031749.html
Sent from the slicer-users mailing list archive at Nabble.com.
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: Slicer slow/laggy on older (hospital) workstations?

adalca
Thanks for your answer.

The nightly build (4.7.0-2017-02-12) behaves the same. I've searched for the
"performance tests" module in both Slicers and couldn't find it. I've also
downloaded your debugging tools extensions, but I can't seem to find such a
test module. Any help would be appreciated.

Thank you,
- Adrian



--
View this message in context: http://slicer-users.65878.n3.nabble.com/Slicer-slow-laggy-on-older-hospital-workstations-tp4031750p4031752.html
Sent from the slicer-users mailing list archive at Nabble.com.
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: Slicer slow/laggy on older (hospital) workstations?

adalca
This post has NOT been accepted by the mailing list yet.
In reply to this post by Andras Lasso-2
Thanks for your answer.

The nightly build (4.7.0-2017-02-12) behaves the same. I've searched for the "performance tests" module in both Slicers and couldn't find it. I've also downloaded your debugging tools extensions, but I can't seem to find such a test module. Any help would be appreciated.

Thank you,
- Adrian
Reply | Threaded
Open this post in threaded view
|

Re: Slicer slow/laggy on older (hospital) workstations?

Andras Lasso-2
In reply to this post by adalca
To make test modules to show up you may need to enable developer mode in menu: Edit / Application settings / Developer.

Andras

-----Original Message-----
From: slicer-users [mailto:[hidden email]] On Behalf Of adalca
Sent: February 13, 2017 16:24
To: SPL Slicer Users <[hidden email]>
Subject: Re: [slicer-users] Slicer slow/laggy on older (hospital) workstations?

Thanks for your answer.

The nightly build (4.7.0-2017-02-12) behaves the same. I've searched for the "performance tests" module in both Slicers and couldn't find it. I've also downloaded your debugging tools extensions, but I can't seem to find such a test module. Any help would be appreciated.

Thank you,
- Adrian



--
View this message in context: http://slicer-users.65878.n3.nabble.com/Slicer-slow-laggy-on-older-hospital-workstations-tp4031750p4031752.html
Sent from the slicer-users mailing list archive at Nabble.com.
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/4.3/FAQ