SlicerRT manual instal on Slicer 4.2.2

classic Classic list List threaded Threaded
21 messages Options
12
Reply | Threaded
Open this post in threaded view
|

SlicerRT manual instal on Slicer 4.2.2

Schopfer Mathieu
Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager. So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Andras Lasso
You can download the zip file of the extension from the dashboard or from
http://slicer.kitware.com/midas3, unzip it, and add the directories under
the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best
would be if the http://slicer.kitware.com/midas3/slicerappstore webpage
would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory,
check the name of the Slicer-XXXXXX.ini file, then search for extensions
corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find
recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in
Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Schopfer Mathieu
Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Jean-Christophe Fillion-Robin
Hi Folks, 

The webpage allowing to download extension [1] has been fixed. 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

Hth
Jc



On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:
Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--
+1 919 869 8849

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Csaba Pinter
Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:
Hi Folks, 

The webpage allowing to download extension [1] has been fixed. 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

Hth
Jc



On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:
Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--
+1 919 869 8849


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Jean-Christophe Fillion-Robin

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:
Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:
Hi Folks, 

The webpage allowing to download extension [1] has been fixed. 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

Hth
Jc



On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:
Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--
<a href="tel:%2B1%20919%20869%208849" value="+19198698849" target="_blank">+1 919 869 8849


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

erol yeniaras
Hey guys,


 and click the Radiotherapy(70), I get No extensions found.

I want to download and use SlicerRT. Is there any other way of doing it?

Erol


On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:
Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:
Hi Folks, 

The webpage allowing to download extension [1] has been fixed. 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

Hth
Jc



On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:
Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--
<a href="tel:%2B1%20919%20869%208849" value="+19198698849" target="_blank">+1 919 869 8849


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: (713) 563-6407

Fax: (713) 563-2986
E-mail: [hidden email]


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Andras Lasso

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--
<a href="tel:%2B1%20919%20869%208849" target="_blank">+1 919 869 8849

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: (713) 563-6407

Fax: (713) 563-2986
E-mail: [hidden email]


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

erol yeniaras
Thanks Andras.

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?


On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--
<a href="tel:%2B1%20919%20869%208849" target="_blank">+1 919 869 8849

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" value="+17135636407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" value="+17135632986" target="_blank">(713) 563-2986
E-mail: [hidden email]




--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: (713) 563-6407

Fax: (713) 563-2986
E-mail: [hidden email]


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Andras Lasso

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--
<a href="tel:%2B1%20919%20869%208849" target="_blank">+1 919 869 8849

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: (713) 563-6407

Fax: (713) 563-2986
E-mail: [hidden email]


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

erol yeniaras
I see... but that`s the same search result with 32 bits:

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

My computer is 32 bits windows and I though I could get SlicerRT based on that info.



On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--
<a href="tel:%2B1%20919%20869%208849" target="_blank">+1 919 869 8849

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" value="+17135636407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" value="+17135632986" target="_blank">(713) 563-2986
E-mail: [hidden email]




--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: (713) 563-6407

Fax: (713) 563-2986
E-mail: [hidden email]


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Andras Lasso

32-bit extension packages are treated with low priority, because 32-bit applications are not usable on real problems.

Your options:

·         Upgrade to a 64-bit OS (I would strongly recommend this option)

·         Check out on the dashboard when a 32-bit packages were generated and use that revision

·         Build Slicer and SliceRT from source

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:35 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

I see... but that`s the same search result with 32 bits:

 

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

 

My computer is 32 bits windows and I though I could get SlicerRT based on that info.

 

 

On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--
<a href="tel:%2B1%20919%20869%208849" target="_blank">+1 919 869 8849

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: (713) 563-6407

Fax: (713) 563-2986
E-mail: [hidden email]


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Jean-Christophe Fillion-Robin

Hi Folks,

Currently build of 32 bit extensions are disabled. This can be verified looking line 13 of the file "factory-south-win7.bat" available at http://github.com/Slicer/DashboardScripts.

If the community think there is a need for 32-bit extensions, we could  re-enable the associated nightly build.

Thanks
jc

--
Sent from my mobile device

On May 1, 2013 2:51 PM, "Andras Lasso" <[hidden email]> wrote:

32-bit extension packages are treated with low priority, because 32-bit applications are not usable on real problems.

Your options:

·         Upgrade to a 64-bit OS (I would strongly recommend this option)

·         Check out on the dashboard when a 32-bit packages were generated and use that revision

·         Build Slicer and SliceRT from source

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:35 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

I see... but that`s the same search result with 32 bits:

 

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

 

My computer is 32 bits windows and I though I could get SlicerRT based on that info.

 

 

On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--
<a href="tel:%2B1%20919%20869%208849" target="_blank">+1 919 869 8849

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" value="+17135636407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" value="+17135632986" target="_blank">(713) 563-2986
E-mail: [hidden email]


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

erol yeniaras
In reply to this post by Andras Lasso
OK Andrass. I am taking your suggestion and working on my 64 bits linux machine.

thanks a lot,
Erol


On Wed, May 1, 2013 at 1:50 PM, Andras Lasso <[hidden email]> wrote:

32-bit extension packages are treated with low priority, because 32-bit applications are not usable on real problems.

Your options:

·         Upgrade to a 64-bit OS (I would strongly recommend this option)

·         Check out on the dashboard when a 32-bit packages were generated and use that revision

·         Build Slicer and SliceRT from source

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:35 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

I see... but that`s the same search result with 32 bits:

 

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

 

My computer is 32 bits windows and I though I could get SlicerRT based on that info.

 

 

On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--
<a href="tel:%2B1%20919%20869%208849" target="_blank">+1 919 869 8849

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" value="+17135636407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" value="+17135632986" target="_blank">(713) 563-2986
E-mail: [hidden email]




--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: (713) 563-6407

Fax: (713) 563-2986
E-mail: [hidden email]


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Sharp, Gregory C.
In reply to this post by Jean-Christophe Fillion-Robin
Hi Jc,
 
Partners (MGH & BWH) corporate desktop computer is 32-bit XP. 
It cannot be upgraded.  Therefore I am often using 32-bit.
 
Greg


From: [hidden email] [mailto:[hidden email]] On Behalf Of Jean-Christophe Fillion-Robin
Sent: Wednesday, May 01, 2013 3:24 PM
To: Andras Lasso
Cc: [hidden email]
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Folks,

Currently build of 32 bit extensions are disabled. This can be verified looking line 13 of the file "factory-south-win7.bat" available at http://github.com/Slicer/DashboardScripts.

If the community think there is a need for 32-bit extensions, we could  re-enable the associated nightly build.

Thanks
jc

--
Sent from my mobile device

On May 1, 2013 2:51 PM, "Andras Lasso" <[hidden email]> wrote:

32-bit extension packages are treated with low priority, because 32-bit applications are not usable on real problems.

Your options:

·         Upgrade to a 64-bit OS (I would strongly recommend this option)

·         Check out on the dashboard when a 32-bit packages were generated and use that revision

·         Build Slicer and SliceRT from source

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:35 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

I see... but that`s the same search result with 32 bits:

 

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

 

My computer is 32 bits windows and I though I could get SlicerRT based on that info.

 

 

On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--
<a href="tel:%2B1%20919%20869%208849" target="_blank">+1 919 869 8849

 

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

 


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank">(713) 563-2986
E-mail: [hidden email]



 

--

Erol YENIARAS, Ph.D.
The University of Texas MD Anderson Cancer Center
Department of Imaging Physics - Unit 1902
1881 East Road
Houston, Texas 77054

United States
Phone: <a href="tel:%28713%29%20563-6407" target="_blank" value="&#43;17135636407">(713) 563-6407

Fax: <a href="tel:%28713%29%20563-2986" target="_blank" value="&#43;17135632986">(713) 563-2986
E-mail: [hidden email]


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Andras Lasso
In reply to this post by Schopfer Mathieu
Windows XP support ends within one year (http://windows.microsoft.com/en-CA/windows/end-support-help). Partners is probably already working on the upgrade plan.

Andras

From: [hidden email]
Sent: ‎2013-‎05-‎01 16:44
To: [hidden email]
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Jc,
 
Partners (MGH & BWH) corporate desktop computer is 32-bit XP. 
It cannot be upgraded.  Therefore I am often using 32-bit.
 
Greg


From: [hidden email] [mailto:[hidden email]] On Behalf Of Jean-Christophe Fillion-Robin
Sent: Wednesday, May 01, 2013 3:24 PM
To: Andras Lasso
Cc: [hidden email]
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Folks,

Currently build of 32 bit extensions are disabled. This can be verified looking line 13 of the file "factory-south-win7.bat" available at http://github.com/Slicer/DashboardScripts.

If the community think there is a need for 32-bit extensions, we could  re-enable the associated nightly build.

Thanks
jc

--
Sent from my mobile device

On May 1, 2013 2:51 PM, "Andras Lasso" <[hidden email]> wrote:

32-bit extension packages are treated with low priority, because 32-bit applications are not usable on real problems.

Your options:

·         Upgrade to a 64-bit OS (I would strongly recommend this option)

·         Check out on the dashboard when a 32-bit packages were generated and use that revision

·         Build Slicer and SliceRT from source

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:35 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

I see... but that`s the same search result with 32 bits:

 

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

 

My computer is 32 bits windows and I though I could get SlicerRT based on that info.

 

 

On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________


[The entire original message is not included.]

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Jean-Christophe Fillion-Robin
Hi Folks, 

In the mean time, should we put effort into building 32-bit version of the extensions ? 

Jc


On Wed, May 1, 2013 at 5:27 PM, Andras Lasso <[hidden email]> wrote:
Windows XP support ends within one year (http://windows.microsoft.com/en-CA/windows/end-support-help). Partners is probably already working on the upgrade plan.

Andras

From: [hidden email]
Sent: 2013-05-01 16:44
To: [hidden email]

Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Jc,
 
Partners (MGH & BWH) corporate desktop computer is 32-bit XP. 
It cannot be upgraded.  Therefore I am often using 32-bit.
 
Greg


From: [hidden email] [mailto:[hidden email]] On Behalf Of Jean-Christophe Fillion-Robin
Sent: Wednesday, May 01, 2013 3:24 PM
To: Andras Lasso
Cc: [hidden email]
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Folks,

Currently build of 32 bit extensions are disabled. This can be verified looking line 13 of the file "factory-south-win7.bat" available at http://github.com/Slicer/DashboardScripts.

If the community think there is a need for 32-bit extensions, we could  re-enable the associated nightly build.

Thanks
jc

--
Sent from my mobile device

On May 1, 2013 2:51 PM, "Andras Lasso" <[hidden email]> wrote:

32-bit extension packages are treated with low priority, because 32-bit applications are not usable on real problems.

Your options:

·         Upgrade to a 64-bit OS (I would strongly recommend this option)

·         Check out on the dashboard when a 32-bit packages were generated and use that revision

·         Build Slicer and SliceRT from source

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:35 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

I see... but that`s the same search result with 32 bits:

 

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

 

My computer is 32 bits windows and I though I could get SlicerRT based on that info.

 

 

On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________


[The entire original message is not included.]

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--
+1 919 869 8849

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Sharp, Gregory C.
Hi Jc,
 
Difficult.  There are good reasons on both sides of this question.
 
- XP is more popular than mac & linux combined
- Slicer developers' time is very valuable, and you have a lot of other things to work on
 
Greg

 

From: Jean-Christophe Fillion-Robin [mailto:[hidden email]]
Sent: Thursday, May 16, 2013 6:33 PM
To: Andras Lasso
Cc: Sharp, Gregory C.; [hidden email]
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Folks, 

In the mean time, should we put effort into building 32-bit version of the extensions ? 

Jc


On Wed, May 1, 2013 at 5:27 PM, Andras Lasso <[hidden email]> wrote:
Windows XP support ends within one year (http://windows.microsoft.com/en-CA/windows/end-support-help). Partners is probably already working on the upgrade plan.

Andras

From: [hidden email]
Sent: 2013-05-01 16:44
To: [hidden email]

Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Jc,
 
Partners (MGH & BWH) corporate desktop computer is 32-bit XP. 
It cannot be upgraded.  Therefore I am often using 32-bit.
 
Greg


From: [hidden email] [mailto:[hidden email]] On Behalf Of Jean-Christophe Fillion-Robin
Sent: Wednesday, May 01, 2013 3:24 PM
To: Andras Lasso
Cc: [hidden email]
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Folks,

Currently build of 32 bit extensions are disabled. This can be verified looking line 13 of the file "factory-south-win7.bat" available at http://github.com/Slicer/DashboardScripts.

If the community think there is a need for 32-bit extensions, we could  re-enable the associated nightly build.

Thanks
jc

--
Sent from my mobile device

On May 1, 2013 2:51 PM, "Andras Lasso" <[hidden email]> wrote:

32-bit extension packages are treated with low priority, because 32-bit applications are not usable on real problems.

Your options:

·         Upgrade to a 64-bit OS (I would strongly recommend this option)

·         Check out on the dashboard when a 32-bit packages were generated and use that revision

·         Build Slicer and SliceRT from source

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:35 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

I see... but that`s the same search result with 32 bits:

 

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

 

My computer is 32 bits windows and I though I could get SlicerRT based on that info.

 

 

On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________


[The entire original message is not included.]

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--
+1 919 869 8849

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Steve Pieper
Hi - 

I'm told that some of the Partners internal applications only work with 32-bit systems, so the IT department doesn't recommend 64 bit windows for non-research PCs.  For that reason I hope we can provide some level of 32-bit support for at least a while longer.

Greg, I'm also told that Partners can supply a windows 7 build - does that not work for you or do you need to stick with XP?  I think for now the same slicer binaries will work on either XP or 7, but we may someday want to drop XP.

-Steve


On Thu, May 16, 2013 at 7:27 PM, Sharp, Gregory C. <[hidden email]> wrote:
Hi Jc,
 
Difficult.  There are good reasons on both sides of this question.
 
- XP is more popular than mac & linux combined
- Slicer developers' time is very valuable, and you have a lot of other things to work on
 
Greg

 

From: Jean-Christophe Fillion-Robin [mailto:[hidden email]]
Sent: Thursday, May 16, 2013 6:33 PM
To: Andras Lasso
Cc: Sharp, Gregory C.; [hidden email]

Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Folks, 

In the mean time, should we put effort into building 32-bit version of the extensions ? 

Jc


On Wed, May 1, 2013 at 5:27 PM, Andras Lasso <[hidden email]> wrote:
Windows XP support ends within one year (http://windows.microsoft.com/en-CA/windows/end-support-help). Partners is probably already working on the upgrade plan.

Andras

From: [hidden email]
Sent: 2013-05-01 16:44
To: [hidden email]

Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Jc,
 
Partners (MGH & BWH) corporate desktop computer is 32-bit XP. 
It cannot be upgraded.  Therefore I am often using 32-bit.
 
Greg


From: [hidden email] [mailto:[hidden email]] On Behalf Of Jean-Christophe Fillion-Robin
Sent: Wednesday, May 01, 2013 3:24 PM
To: Andras Lasso
Cc: [hidden email]
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Folks,

Currently build of 32 bit extensions are disabled. This can be verified looking line 13 of the file "factory-south-win7.bat" available at http://github.com/Slicer/DashboardScripts.

If the community think there is a need for 32-bit extensions, we could  re-enable the associated nightly build.

Thanks
jc

--
Sent from my mobile device

On May 1, 2013 2:51 PM, "Andras Lasso" <[hidden email]> wrote:

32-bit extension packages are treated with low priority, because 32-bit applications are not usable on real problems.

Your options:

·         Upgrade to a 64-bit OS (I would strongly recommend this option)

·         Check out on the dashboard when a 32-bit packages were generated and use that revision

·         Build Slicer and SliceRT from source

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:35 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

I see... but that`s the same search result with 32 bits:

 

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

 

My computer is 32 bits windows and I though I could get SlicerRT based on that info.

 

 

On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________


[The entire original message is not included.]

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--
<a href="tel:%2B1%20919%20869%208849" value="+19198698849" target="_blank">+1 919 869 8849

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: SlicerRT manual instal on Slicer 4.2.2

Sharp, Gregory C.
That's right.  I can't upgrade my Partners PC at this time. 
 
(But also I don't use the Slicer binaries.)
 
Greg
 


From: Steve Pieper [mailto:[hidden email]]
Sent: Thursday, May 16, 2013 7:42 PM
To: Sharp, Gregory C.
Cc: Jean-Christophe Fillion-Robin; [hidden email]
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi - 

I'm told that some of the Partners internal applications only work with 32-bit systems, so the IT department doesn't recommend 64 bit windows for non-research PCs.  For that reason I hope we can provide some level of 32-bit support for at least a while longer.

Greg, I'm also told that Partners can supply a windows 7 build - does that not work for you or do you need to stick with XP?  I think for now the same slicer binaries will work on either XP or 7, but we may someday want to drop XP.

-Steve


On Thu, May 16, 2013 at 7:27 PM, Sharp, Gregory C. <[hidden email]> wrote:
Hi Jc,
 
Difficult.  There are good reasons on both sides of this question.
 
- XP is more popular than mac & linux combined
- Slicer developers' time is very valuable, and you have a lot of other things to work on
 
Greg

 

From: Jean-Christophe Fillion-Robin [mailto:[hidden email]]
Sent: Thursday, May 16, 2013 6:33 PM
To: Andras Lasso
Cc: Sharp, Gregory C.; [hidden email]

Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Folks, 

In the mean time, should we put effort into building 32-bit version of the extensions ? 

Jc


On Wed, May 1, 2013 at 5:27 PM, Andras Lasso <[hidden email]> wrote:
Windows XP support ends within one year (http://windows.microsoft.com/en-CA/windows/end-support-help). Partners is probably already working on the upgrade plan.

Andras

From: [hidden email]
Sent: 2013-05-01 16:44
To: [hidden email]

Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Jc,
 
Partners (MGH & BWH) corporate desktop computer is 32-bit XP. 
It cannot be upgraded.  Therefore I am often using 32-bit.
 
Greg


From: [hidden email] [mailto:[hidden email]] On Behalf Of Jean-Christophe Fillion-Robin
Sent: Wednesday, May 01, 2013 3:24 PM
To: Andras Lasso
Cc: [hidden email]
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi Folks,

Currently build of 32 bit extensions are disabled. This can be verified looking line 13 of the file "factory-south-win7.bat" available at http://github.com/Slicer/DashboardScripts.

If the community think there is a need for 32-bit extensions, we could  re-enable the associated nightly build.

Thanks
jc

--
Sent from my mobile device

On May 1, 2013 2:51 PM, "Andras Lasso" <[hidden email]> wrote:

32-bit extension packages are treated with low priority, because 32-bit applications are not usable on real problems.

Your options:

·         Upgrade to a 64-bit OS (I would strongly recommend this option)

·         Check out on the dashboard when a 32-bit packages were generated and use that revision

·         Build Slicer and SliceRT from source

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:35 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

I see... but that`s the same search result with 32 bits:

 

the user guide at https://www.assembla.com/spaces/slicerrt/wiki/SlicerRt_users_guide says that: ``Windows executables are created for 32-bit systems``

 

My computer is 32 bits windows and I though I could get SlicerRT based on that info.

 

 

On Wed, May 1, 2013 at 1:30 PM, Andras Lasso <[hidden email]> wrote:

Revision 21513 SlicerRT is available on all platforms:

http://slicer.kitware.com/midas3/slicerappstore?os=win&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=linux&arch=amd64&revision=21513&category=&layout=layout

http://slicer.kitware.com/midas3/slicerappstore?os=macosx&arch=amd64&revision=21513&category=&layout=layout

 

Andras

 

From: erol yeniaras [mailto:[hidden email]]
Sent: May 1, 2013 2:24 PM
To: Andras Lasso
Cc: Jean-Christophe Fillion-Robin; [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Thanks Andras.

 

I have revision 21513 installed. And want to get SlicerRT. I entered 21513, no result=> no revision of SlicerRT exists. At that point, how can I know which revision exist? and should I unisntall Slicer and reinstall with that new rev number?

 

On Wed, May 1, 2013 at 1:18 PM, Andras Lasso <[hidden email]> wrote:

Need to specify the revision number, too.

See details at http://www.na-mic.org/Bug/view.php?id=3093

 

Andras

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of erol yeniaras
Sent: May 1, 2013 2:05 PM
To: Jean-Christophe Fillion-Robin
Cc: [hidden email] list
Subject: Re: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

 

Hey guys,

 

 

 and click the Radiotherapy(70), I get No extensions found.

 

I want to download and use SlicerRT. Is there any other way of doing it?

 

Erol

 

On Wed, May 1, 2013 at 10:07 AM, Jean-Christophe Fillion-Robin <[hidden email]> wrote:

Great. That the plan indeed.
Jc

--
Sent from my mobile device

On May 1, 2013 9:26 AM, "Csaba Pintér" <[hidden email]> wrote:

Hi Jc,

Thanks for the fix, it works!

Although it's not very obvious what to do, especially with the revision number.
Would it be possible to indicate that a revision number should go there. Or maybe a drop-down menu with the last N nightlies and the last stable?

Thanks,
csaba

On 5/1/2013 05:08, Jean-Christophe Fillion-Robin wrote:

Hi Folks, 

 

The webpage allowing to download extension [1] has been fixed. 

 

Simply select Os, Arch and enter the corresponding Slicer revision number to be able to download the archive corresponding to an extension.

 

Hth

Jc

 

 

On Fri, Apr 26, 2013 at 3:47 AM, Schopfer Mathieu <[hidden email]> wrote:

Thank you very much. It works now.

-----Message d'origine-----
De : Andras Lasso [mailto:[hidden email]]
Envoyé : jeudi 25 avril 2013 18:30
À : Schopfer Mathieu; [hidden email]
Objet : RE: [slicer-users] SlicerRT manual instal on Slicer 4.2.2


You can download the zip file of the extension from the dashboard or from http://slicer.kitware.com/midas3, unzip it, and add the directories under the lib directory to the module paths in Slicer.

Unfortunately it is quite difficult to find the necessary zip file. The best would be if the http://slicer.kitware.com/midas3/slicerappstore webpage would be fixed.

For now, you can open your c:\Users\...\AppData\Roaming\NA-MIC\ directory, check the name of the Slicer-XXXXXX.ini file, then search for extensions corresponding to this version:
http://slicer.kitware.com/midas3/search/index?q=XXXXX (e.g.,
http://slicer.kitware.com/midas3/search/index?q=21915)

Andras


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Schopfer Mathieu
Sent: Thursday, April 25, 2013 9:54 AM
To: [hidden email]
Subject: [slicer-users] SlicerRT manual instal on Slicer 4.2.2

Hi!

Due the proxy settings in my institution, I can't use the ExtensionsManager.
So, I'd like to download SlicerRT manually. Though, I can't seem to find recent builds on slicer.kitware.com.
Where can I find builds for Windows 64-bit ? Or how can I set up a proxy in Slicer ?

Best regards,
Mathieu Schopfer
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email]
with unsubscribe as the subject

_______________________________________________


[The entire original message is not included.]

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject



--
<a href="tel:%2B1%20919%20869%208849" target="_blank" value="&#43;19198698849">+1 919 869 8849

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
12