getbuildtest error- Slicer3.6 checkout

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

getbuildtest error- Slicer3.6 checkout

swallace
Hi all,

Get this error message when trying to run getbuildtest on Slicer3.6:

panamint:swallace:1:31pm[96] ./Scripts/getbuildtest.tcl -t ""
Sourcing
/autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
Slicer3_HOME is
/autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
making with make -j 4
running: svn switch http://svn.slicer.org/Slicer3/trunk
At revision 15105.

running: sh ./Scripts/genlib.tcl
/autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
-64
Sourcing
/autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
Slicer3_HOME is
/autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
running: svn co http://svn.scipy.org/svn/numpy/branches/1.3.x numpy
Checked out revision 8716.

running:
/autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib/python-build/bin/python
./setup.py build --fcompiler=xxx
svn: error while loading shared libraries: libsvn_fs_util-1.so.0: cannot
open shared object file: No such file or directory
Traceback (most recent call last):
  File "./setup.py", line 104, in <module>
    FULLVERSION += svn_version()
  File "./setup.py", line 86, in svn_version
    raise ValueError("Error while parsing svn version ?")
ValueError: Error while parsing svn version ?

child process exited abnormally
1
    while executing
"error $ret"
    (procedure "runcmd" line 23)
    invoked from within
"runcmd $::Slicer3_LIB/python-build/bin/python ./setup.py build
--fcompiler=xxx"
    invoked from within
"if {  [BuildThis $::NUMPY_TEST_FILE "python"] && !$::USE_SYSTEM_PYTHON &&
[string tolower $::USE_PYTHON] == "on" } {

    set ::env(PYTHONHOME) $::Sli..."
    (file "./Scripts/genlib.tcl" line 762)

child process exited abnormally
ERROR: failed to run getbuildtest: sh ./Scripts/genlib.tcl
/autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
-64



I checkd out the code from  http://svn.slicer.org/Slicer3/trunk.

Many thanks,

Stuart
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: [slicer-devel] getbuildtest error- Slicer3.6 checkout

pieper
Administrator
Hi Stuart -

That's odd - it looks like your svn command is failing when building
numpy.  At least for me on a ubuntu machine, the file it's complaining
about should be provided by the 'libsvn1' package and be installed in
/usr/lib.  Can you try something like the command below and see if it
shows up for you?

pieper@boggs:~$ locate libsvn_fs_util
/usr/lib/libsvn_fs_util-1.so.1
/usr/lib/libsvn_fs_util-1.so.1.0.0

I just tried deleting and rebuilding my python code and all worked fine.

-Steve

On 09/29/2010 01:39 PM, [hidden email] wrote:

> Hi all,
>
> Get this error message when trying to run getbuildtest on Slicer3.6:
>
> panamint:swallace:1:31pm[96] ./Scripts/getbuildtest.tcl -t ""
> Sourcing
> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
> Slicer3_HOME is
> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
> making with make -j 4
> running: svn switch http://svn.slicer.org/Slicer3/trunk
> At revision 15105.
>
> running: sh ./Scripts/genlib.tcl
> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
> -64
> Sourcing
> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
> Slicer3_HOME is
> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
> running: svn co http://svn.scipy.org/svn/numpy/branches/1.3.x numpy
> Checked out revision 8716.
>
> running:
> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib/python-build/bin/python
> ./setup.py build --fcompiler=xxx
> svn: error while loading shared libraries: libsvn_fs_util-1.so.0: cannot
> open shared object file: No such file or directory
> Traceback (most recent call last):
>    File "./setup.py", line 104, in<module>
>      FULLVERSION += svn_version()
>    File "./setup.py", line 86, in svn_version
>      raise ValueError("Error while parsing svn version ?")
> ValueError: Error while parsing svn version ?
>
> child process exited abnormally
> 1
>      while executing
> "error $ret"
>      (procedure "runcmd" line 23)
>      invoked from within
> "runcmd $::Slicer3_LIB/python-build/bin/python ./setup.py build
> --fcompiler=xxx"
>      invoked from within
> "if {  [BuildThis $::NUMPY_TEST_FILE "python"]&&  !$::USE_SYSTEM_PYTHON&&
> [string tolower $::USE_PYTHON] == "on" } {
>
>      set ::env(PYTHONHOME) $::Sli..."
>      (file "./Scripts/genlib.tcl" line 762)
>
> child process exited abnormally
> ERROR: failed to run getbuildtest: sh ./Scripts/genlib.tcl
> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
> -64
>
>
>
> I checkd out the code from  http://svn.slicer.org/Slicer3/trunk.
>
> Many thanks,
>
> Stuart
> _______________________________________________
> slicer-devel mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: [slicer-devel] getbuildtest error- Slicer3.6 checkout

swallace
No luck:

[panamint:Slicer3] (nmr-dev-env) locate libsvn_fs_util
locate: can not open `/var/lib/mlocate/mlocate.db': No such file or directory

Using a centos 5 machine and the Martinos environment, but haven't run
into this error previously.

On Wed, September 29, 2010 2:24 pm, Steve Pieper wrote:

> Hi Stuart -
>
> That's odd - it looks like your svn command is failing when building
> numpy.  At least for me on a ubuntu machine, the file it's complaining
> about should be provided by the 'libsvn1' package and be installed in
> /usr/lib.  Can you try something like the command below and see if it
> shows up for you?
>
> pieper@boggs:~$ locate libsvn_fs_util
> /usr/lib/libsvn_fs_util-1.so.1
> /usr/lib/libsvn_fs_util-1.so.1.0.0
>
> I just tried deleting and rebuilding my python code and all worked fine.
>
> -Steve
>
> On 09/29/2010 01:39 PM, [hidden email] wrote:
>> Hi all,
>>
>> Get this error message when trying to run getbuildtest on Slicer3.6:
>>
>> panamint:swallace:1:31pm[96] ./Scripts/getbuildtest.tcl -t ""
>> Sourcing
>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>> Slicer3_HOME is
>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>> making with make -j 4
>> running: svn switch http://svn.slicer.org/Slicer3/trunk
>> At revision 15105.
>>
>> running: sh ./Scripts/genlib.tcl
>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>> -64
>> Sourcing
>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>> Slicer3_HOME is
>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>> running: svn co http://svn.scipy.org/svn/numpy/branches/1.3.x numpy
>> Checked out revision 8716.
>>
>> running:
>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib/python-build/bin/python
>> ./setup.py build --fcompiler=xxx
>> svn: error while loading shared libraries: libsvn_fs_util-1.so.0: cannot
>> open shared object file: No such file or directory
>> Traceback (most recent call last):
>>    File "./setup.py", line 104, in<module>
>>      FULLVERSION += svn_version()
>>    File "./setup.py", line 86, in svn_version
>>      raise ValueError("Error while parsing svn version ?")
>> ValueError: Error while parsing svn version ?
>>
>> child process exited abnormally
>> 1
>>      while executing
>> "error $ret"
>>      (procedure "runcmd" line 23)
>>      invoked from within
>> "runcmd $::Slicer3_LIB/python-build/bin/python ./setup.py build
>> --fcompiler=xxx"
>>      invoked from within
>> "if {  [BuildThis $::NUMPY_TEST_FILE "python"]&&
>> !$::USE_SYSTEM_PYTHON&&
>> [string tolower $::USE_PYTHON] == "on" } {
>>
>>      set ::env(PYTHONHOME) $::Sli..."
>>      (file "./Scripts/genlib.tcl" line 762)
>>
>> child process exited abnormally
>> ERROR: failed to run getbuildtest: sh ./Scripts/genlib.tcl
>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>> -64
>>
>>
>>
>> I checkd out the code from  http://svn.slicer.org/Slicer3/trunk.
>>
>> Many thanks,
>>
>> Stuart
>> _______________________________________________
>> slicer-devel mailing list
>> [hidden email]
>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>> To unsubscribe: send email to
>> [hidden email] with unsubscribe as the
>> subject
>
>
>

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: [slicer-devel] getbuildtest error- Slicer3.6 checkout

pieper
Administrator
Looks like the 'locate' command is not set up on your machine (would
need to run 'updatedb' as root to make it work).  But this is a side issue.

svn appears to be working for you except when it is being called from
within the numpy build script.  I can't really explain that, but if it
just started happening it's probably related to your machine config
somehow - I don't think any of the build stuff for python in the
slicer-3-6 branch has changed in a very long time...

-Steve


On 09/29/2010 02:35 PM, [hidden email] wrote:

> No luck:
>
> [panamint:Slicer3] (nmr-dev-env) locate libsvn_fs_util
> locate: can not open `/var/lib/mlocate/mlocate.db': No such file or directory
>
> Using a centos 5 machine and the Martinos environment, but haven't run
> into this error previously.
>
> On Wed, September 29, 2010 2:24 pm, Steve Pieper wrote:
>> Hi Stuart -
>>
>> That's odd - it looks like your svn command is failing when building
>> numpy.  At least for me on a ubuntu machine, the file it's complaining
>> about should be provided by the 'libsvn1' package and be installed in
>> /usr/lib.  Can you try something like the command below and see if it
>> shows up for you?
>>
>> pieper@boggs:~$ locate libsvn_fs_util
>> /usr/lib/libsvn_fs_util-1.so.1
>> /usr/lib/libsvn_fs_util-1.so.1.0.0
>>
>> I just tried deleting and rebuilding my python code and all worked fine.
>>
>> -Steve
>>
>> On 09/29/2010 01:39 PM, [hidden email] wrote:
>>> Hi all,
>>>
>>> Get this error message when trying to run getbuildtest on Slicer3.6:
>>>
>>> panamint:swallace:1:31pm[96] ./Scripts/getbuildtest.tcl -t ""
>>> Sourcing
>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>> Slicer3_HOME is
>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>> making with make -j 4
>>> running: svn switch http://svn.slicer.org/Slicer3/trunk
>>> At revision 15105.
>>>
>>> running: sh ./Scripts/genlib.tcl
>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>> -64
>>> Sourcing
>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>> Slicer3_HOME is
>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>> running: svn co http://svn.scipy.org/svn/numpy/branches/1.3.x numpy
>>> Checked out revision 8716.
>>>
>>> running:
>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib/python-build/bin/python
>>> ./setup.py build --fcompiler=xxx
>>> svn: error while loading shared libraries: libsvn_fs_util-1.so.0: cannot
>>> open shared object file: No such file or directory
>>> Traceback (most recent call last):
>>>     File "./setup.py", line 104, in<module>
>>>       FULLVERSION += svn_version()
>>>     File "./setup.py", line 86, in svn_version
>>>       raise ValueError("Error while parsing svn version ?")
>>> ValueError: Error while parsing svn version ?
>>>
>>> child process exited abnormally
>>> 1
>>>       while executing
>>> "error $ret"
>>>       (procedure "runcmd" line 23)
>>>       invoked from within
>>> "runcmd $::Slicer3_LIB/python-build/bin/python ./setup.py build
>>> --fcompiler=xxx"
>>>       invoked from within
>>> "if {  [BuildThis $::NUMPY_TEST_FILE "python"]&&
>>> !$::USE_SYSTEM_PYTHON&&
>>> [string tolower $::USE_PYTHON] == "on" } {
>>>
>>>       set ::env(PYTHONHOME) $::Sli..."
>>>       (file "./Scripts/genlib.tcl" line 762)
>>>
>>> child process exited abnormally
>>> ERROR: failed to run getbuildtest: sh ./Scripts/genlib.tcl
>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>> -64
>>>
>>>
>>>
>>> I checkd out the code from  http://svn.slicer.org/Slicer3/trunk.
>>>
>>> Many thanks,
>>>
>>> Stuart
>>> _______________________________________________
>>> slicer-devel mailing list
>>> [hidden email]
>>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>>> To unsubscribe: send email to
>>> [hidden email] with unsubscribe as the
>>> subject
>>
>>
>>
>
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: [slicer-devel] getbuildtest error- Slicer3.6 checkout

Daniel Haehn
Hi Stuart,

you should check

ldd -r /usr/bin/svnserve

and see if there is an entry like

libsvn_fs_util-1.so.0 => /usr/lib/libsvn_fs_util-1.so.0 (0x00857000)

Also check if the file exists under /usr/lib or /usr/lib64

But I agree with Steve, indeed it is strange that it only happens with Python.

Daniel

On Sep 29, 2010, at 2:45 PM, Steve Pieper wrote:

> Looks like the 'locate' command is not set up on your machine (would
> need to run 'updatedb' as root to make it work).  But this is a side issue.
>
> svn appears to be working for you except when it is being called from
> within the numpy build script.  I can't really explain that, but if it
> just started happening it's probably related to your machine config
> somehow - I don't think any of the build stuff for python in the
> slicer-3-6 branch has changed in a very long time...
>
> -Steve
>
>
> On 09/29/2010 02:35 PM, [hidden email] wrote:
>> No luck:
>>
>> [panamint:Slicer3] (nmr-dev-env) locate libsvn_fs_util
>> locate: can not open `/var/lib/mlocate/mlocate.db': No such file or directory
>>
>> Using a centos 5 machine and the Martinos environment, but haven't run
>> into this error previously.
>>
>> On Wed, September 29, 2010 2:24 pm, Steve Pieper wrote:
>>> Hi Stuart -
>>>
>>> That's odd - it looks like your svn command is failing when building
>>> numpy.  At least for me on a ubuntu machine, the file it's complaining
>>> about should be provided by the 'libsvn1' package and be installed in
>>> /usr/lib.  Can you try something like the command below and see if it
>>> shows up for you?
>>>
>>> pieper@boggs:~$ locate libsvn_fs_util
>>> /usr/lib/libsvn_fs_util-1.so.1
>>> /usr/lib/libsvn_fs_util-1.so.1.0.0
>>>
>>> I just tried deleting and rebuilding my python code and all worked fine.
>>>
>>> -Steve
>>>
>>> On 09/29/2010 01:39 PM, [hidden email] wrote:
>>>> Hi all,
>>>>
>>>> Get this error message when trying to run getbuildtest on Slicer3.6:
>>>>
>>>> panamint:swallace:1:31pm[96] ./Scripts/getbuildtest.tcl -t ""
>>>> Sourcing
>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>>> Slicer3_HOME is
>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>>> making with make -j 4
>>>> running: svn switch http://svn.slicer.org/Slicer3/trunk
>>>> At revision 15105.
>>>>
>>>> running: sh ./Scripts/genlib.tcl
>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>>> -64
>>>> Sourcing
>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>>> Slicer3_HOME is
>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>>> running: svn co http://svn.scipy.org/svn/numpy/branches/1.3.x numpy
>>>> Checked out revision 8716.
>>>>
>>>> running:
>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib/python-build/bin/python
>>>> ./setup.py build --fcompiler=xxx
>>>> svn: error while loading shared libraries: libsvn_fs_util-1.so.0: cannot
>>>> open shared object file: No such file or directory
>>>> Traceback (most recent call last):
>>>>    File "./setup.py", line 104, in<module>
>>>>      FULLVERSION += svn_version()
>>>>    File "./setup.py", line 86, in svn_version
>>>>      raise ValueError("Error while parsing svn version ?")
>>>> ValueError: Error while parsing svn version ?
>>>>
>>>> child process exited abnormally
>>>> 1
>>>>      while executing
>>>> "error $ret"
>>>>      (procedure "runcmd" line 23)
>>>>      invoked from within
>>>> "runcmd $::Slicer3_LIB/python-build/bin/python ./setup.py build
>>>> --fcompiler=xxx"
>>>>      invoked from within
>>>> "if {  [BuildThis $::NUMPY_TEST_FILE "python"]&&
>>>> !$::USE_SYSTEM_PYTHON&&
>>>> [string tolower $::USE_PYTHON] == "on" } {
>>>>
>>>>      set ::env(PYTHONHOME) $::Sli..."
>>>>      (file "./Scripts/genlib.tcl" line 762)
>>>>
>>>> child process exited abnormally
>>>> ERROR: failed to run getbuildtest: sh ./Scripts/genlib.tcl
>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>>> -64
>>>>
>>>>
>>>>
>>>> I checkd out the code from  http://svn.slicer.org/Slicer3/trunk.
>>>>
>>>> Many thanks,
>>>>
>>>> Stuart
>>>> _______________________________________________
>>>> slicer-devel mailing list
>>>> [hidden email]
>>>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>>>> To unsubscribe: send email to
>>>> [hidden email] with unsubscribe as the
>>>> subject
>>>
>>>
>>>
>>
> _______________________________________________
> slicer-devel mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: [slicer-devel] getbuildtest error- Slicer3.6 checkout

swallace
Hi,

This file isn't found, but plenty of other libsvn_xx are:

[panamint:Slicer3] (nmr-dev-env) ldd -r /usr/bin/svnserve
        libsvn_repos-1.so.0 =>
/usr/pubsw/packages/svn/current/lib/libsvn_repos-1.so.0
(0x00002b8836050000)
        libsvn_fs-1.so.0 =>
/usr/pubsw/packages/svn/current/lib/libsvn_fs-1.so.0
(0x00002b883624f000)
        libsvn_fs_fs-1.so.0 =>
/usr/pubsw/packages/svn/current/lib/libsvn_fs_fs-1.so.0
(0x00002b8836356000)
        libsvn_fs_base-1.so.0 => /usr/lib64/libsvn_fs_base-1.so.0
(0x00002b88364a9000)
        libsvn_delta-1.so.0 =>
/usr/pubsw/packages/svn/current/lib/libsvn_delta-1.so.0
(0x00002b88366d3000)
        libsvn_subr-1.so.0 =>
/usr/pubsw/packages/svn/current/lib/libsvn_subr-1.so.0
(0x00002b88367de000)
        libsvn_ra_svn-1.so.0 =>
/usr/pubsw/packages/svn/current/lib/libsvn_ra_svn-1.so.0
(0x00002b8836995000)

While I'm curious as to whether there's a fix or not, I've had no issues
checking out 3.6 on my personal copmuter's ubuntu, so no harm.

Thanks for the input everyone!

On Wed, September 29, 2010 2:58 pm, Daniel Haehn wrote:

> Hi Stuart,
>
> you should check
>
> ldd -r /usr/bin/svnserve
>
> and see if there is an entry like
>
> libsvn_fs_util-1.so.0 => /usr/lib/libsvn_fs_util-1.so.0 (0x00857000)
>
> Also check if the file exists under /usr/lib or /usr/lib64
>
> But I agree with Steve, indeed it is strange that it only happens with
> Python.
>
> Daniel
>
> On Sep 29, 2010, at 2:45 PM, Steve Pieper wrote:
>
>> Looks like the 'locate' command is not set up on your machine (would
>> need to run 'updatedb' as root to make it work).  But this is a side
>> issue.
>>
>> svn appears to be working for you except when it is being called from
>> within the numpy build script.  I can't really explain that, but if it
>> just started happening it's probably related to your machine config
>> somehow - I don't think any of the build stuff for python in the
>> slicer-3-6 branch has changed in a very long time...
>>
>> -Steve
>>
>>
>> On 09/29/2010 02:35 PM, [hidden email] wrote:
>>> No luck:
>>>
>>> [panamint:Slicer3] (nmr-dev-env) locate libsvn_fs_util
>>> locate: can not open `/var/lib/mlocate/mlocate.db': No such file or
>>> directory
>>>
>>> Using a centos 5 machine and the Martinos environment, but haven't run
>>> into this error previously.
>>>
>>> On Wed, September 29, 2010 2:24 pm, Steve Pieper wrote:
>>>> Hi Stuart -
>>>>
>>>> That's odd - it looks like your svn command is failing when building
>>>> numpy.  At least for me on a ubuntu machine, the file it's complaining
>>>> about should be provided by the 'libsvn1' package and be installed in
>>>> /usr/lib.  Can you try something like the command below and see if it
>>>> shows up for you?
>>>>
>>>> pieper@boggs:~$ locate libsvn_fs_util
>>>> /usr/lib/libsvn_fs_util-1.so.1
>>>> /usr/lib/libsvn_fs_util-1.so.1.0.0
>>>>
>>>> I just tried deleting and rebuilding my python code and all worked
>>>> fine.
>>>>
>>>> -Steve
>>>>
>>>> On 09/29/2010 01:39 PM, [hidden email] wrote:
>>>>> Hi all,
>>>>>
>>>>> Get this error message when trying to run getbuildtest on Slicer3.6:
>>>>>
>>>>> panamint:swallace:1:31pm[96] ./Scripts/getbuildtest.tcl -t ""
>>>>> Sourcing
>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>>>> Slicer3_HOME is
>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>>>> making with make -j 4
>>>>> running: svn switch http://svn.slicer.org/Slicer3/trunk
>>>>> At revision 15105.
>>>>>
>>>>> running: sh ./Scripts/genlib.tcl
>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>>>> -64
>>>>> Sourcing
>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>>>> Slicer3_HOME is
>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>>>> running: svn co http://svn.scipy.org/svn/numpy/branches/1.3.x numpy
>>>>> Checked out revision 8716.
>>>>>
>>>>> running:
>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib/python-build/bin/python
>>>>> ./setup.py build --fcompiler=xxx
>>>>> svn: error while loading shared libraries: libsvn_fs_util-1.so.0:
>>>>> cannot
>>>>> open shared object file: No such file or directory
>>>>> Traceback (most recent call last):
>>>>>    File "./setup.py", line 104, in<module>
>>>>>      FULLVERSION += svn_version()
>>>>>    File "./setup.py", line 86, in svn_version
>>>>>      raise ValueError("Error while parsing svn version ?")
>>>>> ValueError: Error while parsing svn version ?
>>>>>
>>>>> child process exited abnormally
>>>>> 1
>>>>>      while executing
>>>>> "error $ret"
>>>>>      (procedure "runcmd" line 23)
>>>>>      invoked from within
>>>>> "runcmd $::Slicer3_LIB/python-build/bin/python ./setup.py build
>>>>> --fcompiler=xxx"
>>>>>      invoked from within
>>>>> "if {  [BuildThis $::NUMPY_TEST_FILE "python"]&&
>>>>> !$::USE_SYSTEM_PYTHON&&
>>>>> [string tolower $::USE_PYTHON] == "on" } {
>>>>>
>>>>>      set ::env(PYTHONHOME) $::Sli..."
>>>>>      (file "./Scripts/genlib.tcl" line 762)
>>>>>
>>>>> child process exited abnormally
>>>>> ERROR: failed to run getbuildtest: sh ./Scripts/genlib.tcl
>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>>>> -64
>>>>>
>>>>>
>>>>>
>>>>> I checkd out the code from  http://svn.slicer.org/Slicer3/trunk.
>>>>>
>>>>> Many thanks,
>>>>>
>>>>> Stuart
>>>>> _______________________________________________
>>>>> slicer-devel mailing list
>>>>> [hidden email]
>>>>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>>>>> To unsubscribe: send email to
>>>>> [hidden email] with unsubscribe as the
>>>>> subject
>>>>
>>>>
>>>>
>>>
>> _______________________________________________
>> slicer-devel mailing list
>> [hidden email]
>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>> To unsubscribe: send email to
>> [hidden email] with unsubscribe as the
>> subject
>
>
>
>

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: [slicer-devel] getbuildtest error- Slicer3.6 checkout

Daniel Haehn
Hi Stuart,

so the lib is not there. You probably have to talk to your administrator to get it on centOS. Then you can ask him to enable the locate command as well :)

Bye,
Daniel

On Sep 29, 2010, at 3:08 PM, [hidden email] wrote:

> Hi,
>
> This file isn't found, but plenty of other libsvn_xx are:
>
> [panamint:Slicer3] (nmr-dev-env) ldd -r /usr/bin/svnserve
>        libsvn_repos-1.so.0 =>
> /usr/pubsw/packages/svn/current/lib/libsvn_repos-1.so.0
> (0x00002b8836050000)
>        libsvn_fs-1.so.0 =>
> /usr/pubsw/packages/svn/current/lib/libsvn_fs-1.so.0
> (0x00002b883624f000)
>        libsvn_fs_fs-1.so.0 =>
> /usr/pubsw/packages/svn/current/lib/libsvn_fs_fs-1.so.0
> (0x00002b8836356000)
>        libsvn_fs_base-1.so.0 => /usr/lib64/libsvn_fs_base-1.so.0
> (0x00002b88364a9000)
>        libsvn_delta-1.so.0 =>
> /usr/pubsw/packages/svn/current/lib/libsvn_delta-1.so.0
> (0x00002b88366d3000)
>        libsvn_subr-1.so.0 =>
> /usr/pubsw/packages/svn/current/lib/libsvn_subr-1.so.0
> (0x00002b88367de000)
>        libsvn_ra_svn-1.so.0 =>
> /usr/pubsw/packages/svn/current/lib/libsvn_ra_svn-1.so.0
> (0x00002b8836995000)
>
> While I'm curious as to whether there's a fix or not, I've had no issues
> checking out 3.6 on my personal copmuter's ubuntu, so no harm.
>
> Thanks for the input everyone!
>
> On Wed, September 29, 2010 2:58 pm, Daniel Haehn wrote:
>> Hi Stuart,
>>
>> you should check
>>
>> ldd -r /usr/bin/svnserve
>>
>> and see if there is an entry like
>>
>> libsvn_fs_util-1.so.0 => /usr/lib/libsvn_fs_util-1.so.0 (0x00857000)
>>
>> Also check if the file exists under /usr/lib or /usr/lib64
>>
>> But I agree with Steve, indeed it is strange that it only happens with
>> Python.
>>
>> Daniel
>>
>> On Sep 29, 2010, at 2:45 PM, Steve Pieper wrote:
>>
>>> Looks like the 'locate' command is not set up on your machine (would
>>> need to run 'updatedb' as root to make it work).  But this is a side
>>> issue.
>>>
>>> svn appears to be working for you except when it is being called from
>>> within the numpy build script.  I can't really explain that, but if it
>>> just started happening it's probably related to your machine config
>>> somehow - I don't think any of the build stuff for python in the
>>> slicer-3-6 branch has changed in a very long time...
>>>
>>> -Steve
>>>
>>>
>>> On 09/29/2010 02:35 PM, [hidden email] wrote:
>>>> No luck:
>>>>
>>>> [panamint:Slicer3] (nmr-dev-env) locate libsvn_fs_util
>>>> locate: can not open `/var/lib/mlocate/mlocate.db': No such file or
>>>> directory
>>>>
>>>> Using a centos 5 machine and the Martinos environment, but haven't run
>>>> into this error previously.
>>>>
>>>> On Wed, September 29, 2010 2:24 pm, Steve Pieper wrote:
>>>>> Hi Stuart -
>>>>>
>>>>> That's odd - it looks like your svn command is failing when building
>>>>> numpy.  At least for me on a ubuntu machine, the file it's complaining
>>>>> about should be provided by the 'libsvn1' package and be installed in
>>>>> /usr/lib.  Can you try something like the command below and see if it
>>>>> shows up for you?
>>>>>
>>>>> pieper@boggs:~$ locate libsvn_fs_util
>>>>> /usr/lib/libsvn_fs_util-1.so.1
>>>>> /usr/lib/libsvn_fs_util-1.so.1.0.0
>>>>>
>>>>> I just tried deleting and rebuilding my python code and all worked
>>>>> fine.
>>>>>
>>>>> -Steve
>>>>>
>>>>> On 09/29/2010 01:39 PM, [hidden email] wrote:
>>>>>> Hi all,
>>>>>>
>>>>>> Get this error message when trying to run getbuildtest on Slicer3.6:
>>>>>>
>>>>>> panamint:swallace:1:31pm[96] ./Scripts/getbuildtest.tcl -t ""
>>>>>> Sourcing
>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>>>>> Slicer3_HOME is
>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>>>>> making with make -j 4
>>>>>> running: svn switch http://svn.slicer.org/Slicer3/trunk
>>>>>> At revision 15105.
>>>>>>
>>>>>> running: sh ./Scripts/genlib.tcl
>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>>>>> -64
>>>>>> Sourcing
>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>>>>> Slicer3_HOME is
>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>>>>> running: svn co http://svn.scipy.org/svn/numpy/branches/1.3.x numpy
>>>>>> Checked out revision 8716.
>>>>>>
>>>>>> running:
>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib/python-build/bin/python
>>>>>> ./setup.py build --fcompiler=xxx
>>>>>> svn: error while loading shared libraries: libsvn_fs_util-1.so.0:
>>>>>> cannot
>>>>>> open shared object file: No such file or directory
>>>>>> Traceback (most recent call last):
>>>>>>   File "./setup.py", line 104, in<module>
>>>>>>     FULLVERSION += svn_version()
>>>>>>   File "./setup.py", line 86, in svn_version
>>>>>>     raise ValueError("Error while parsing svn version ?")
>>>>>> ValueError: Error while parsing svn version ?
>>>>>>
>>>>>> child process exited abnormally
>>>>>> 1
>>>>>>     while executing
>>>>>> "error $ret"
>>>>>>     (procedure "runcmd" line 23)
>>>>>>     invoked from within
>>>>>> "runcmd $::Slicer3_LIB/python-build/bin/python ./setup.py build
>>>>>> --fcompiler=xxx"
>>>>>>     invoked from within
>>>>>> "if {  [BuildThis $::NUMPY_TEST_FILE "python"]&&
>>>>>> !$::USE_SYSTEM_PYTHON&&
>>>>>> [string tolower $::USE_PYTHON] == "on" } {
>>>>>>
>>>>>>     set ::env(PYTHONHOME) $::Sli..."
>>>>>>     (file "./Scripts/genlib.tcl" line 762)
>>>>>>
>>>>>> child process exited abnormally
>>>>>> ERROR: failed to run getbuildtest: sh ./Scripts/genlib.tcl
>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>>>>> -64
>>>>>>
>>>>>>
>>>>>>
>>>>>> I checkd out the code from  http://svn.slicer.org/Slicer3/trunk.
>>>>>>
>>>>>> Many thanks,
>>>>>>
>>>>>> Stuart
>>>>>> _______________________________________________
>>>>>> slicer-devel mailing list
>>>>>> [hidden email]
>>>>>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>>>>>> To unsubscribe: send email to
>>>>>> [hidden email] with unsubscribe as the
>>>>>> subject
>>>>>
>>>>>
>>>>>
>>>>
>>> _______________________________________________
>>> slicer-devel mailing list
>>> [hidden email]
>>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>>> To unsubscribe: send email to
>>> [hidden email] with unsubscribe as the
>>> subject
>>
>>
>>
>>
>

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: [slicer-devel] getbuildtest error- Slicer3.6 checkout

swallace
Yes, that would be nice  :) Thanks again.

On Wed, September 29, 2010 3:14 pm, Daniel Haehn wrote:

> Hi Stuart,
>
> so the lib is not there. You probably have to talk to your administrator
> to get it on centOS. Then you can ask him to enable the locate command as
> well :)
>
> Bye,
> Daniel
>
> On Sep 29, 2010, at 3:08 PM, [hidden email] wrote:
>
>> Hi,
>>
>> This file isn't found, but plenty of other libsvn_xx are:
>>
>> [panamint:Slicer3] (nmr-dev-env) ldd -r /usr/bin/svnserve
>>        libsvn_repos-1.so.0 =>
>> /usr/pubsw/packages/svn/current/lib/libsvn_repos-1.so.0
>> (0x00002b8836050000)
>>        libsvn_fs-1.so.0 =>
>> /usr/pubsw/packages/svn/current/lib/libsvn_fs-1.so.0
>> (0x00002b883624f000)
>>        libsvn_fs_fs-1.so.0 =>
>> /usr/pubsw/packages/svn/current/lib/libsvn_fs_fs-1.so.0
>> (0x00002b8836356000)
>>        libsvn_fs_base-1.so.0 => /usr/lib64/libsvn_fs_base-1.so.0
>> (0x00002b88364a9000)
>>        libsvn_delta-1.so.0 =>
>> /usr/pubsw/packages/svn/current/lib/libsvn_delta-1.so.0
>> (0x00002b88366d3000)
>>        libsvn_subr-1.so.0 =>
>> /usr/pubsw/packages/svn/current/lib/libsvn_subr-1.so.0
>> (0x00002b88367de000)
>>        libsvn_ra_svn-1.so.0 =>
>> /usr/pubsw/packages/svn/current/lib/libsvn_ra_svn-1.so.0
>> (0x00002b8836995000)
>>
>> While I'm curious as to whether there's a fix or not, I've had no issues
>> checking out 3.6 on my personal copmuter's ubuntu, so no harm.
>>
>> Thanks for the input everyone!
>>
>> On Wed, September 29, 2010 2:58 pm, Daniel Haehn wrote:
>>> Hi Stuart,
>>>
>>> you should check
>>>
>>> ldd -r /usr/bin/svnserve
>>>
>>> and see if there is an entry like
>>>
>>> libsvn_fs_util-1.so.0 => /usr/lib/libsvn_fs_util-1.so.0 (0x00857000)
>>>
>>> Also check if the file exists under /usr/lib or /usr/lib64
>>>
>>> But I agree with Steve, indeed it is strange that it only happens with
>>> Python.
>>>
>>> Daniel
>>>
>>> On Sep 29, 2010, at 2:45 PM, Steve Pieper wrote:
>>>
>>>> Looks like the 'locate' command is not set up on your machine (would
>>>> need to run 'updatedb' as root to make it work).  But this is a side
>>>> issue.
>>>>
>>>> svn appears to be working for you except when it is being called from
>>>> within the numpy build script.  I can't really explain that, but if it
>>>> just started happening it's probably related to your machine config
>>>> somehow - I don't think any of the build stuff for python in the
>>>> slicer-3-6 branch has changed in a very long time...
>>>>
>>>> -Steve
>>>>
>>>>
>>>> On 09/29/2010 02:35 PM, [hidden email] wrote:
>>>>> No luck:
>>>>>
>>>>> [panamint:Slicer3] (nmr-dev-env) locate libsvn_fs_util
>>>>> locate: can not open `/var/lib/mlocate/mlocate.db': No such file or
>>>>> directory
>>>>>
>>>>> Using a centos 5 machine and the Martinos environment, but haven't
>>>>> run
>>>>> into this error previously.
>>>>>
>>>>> On Wed, September 29, 2010 2:24 pm, Steve Pieper wrote:
>>>>>> Hi Stuart -
>>>>>>
>>>>>> That's odd - it looks like your svn command is failing when building
>>>>>> numpy.  At least for me on a ubuntu machine, the file it's
>>>>>> complaining
>>>>>> about should be provided by the 'libsvn1' package and be installed
>>>>>> in
>>>>>> /usr/lib.  Can you try something like the command below and see if
>>>>>> it
>>>>>> shows up for you?
>>>>>>
>>>>>> pieper@boggs:~$ locate libsvn_fs_util
>>>>>> /usr/lib/libsvn_fs_util-1.so.1
>>>>>> /usr/lib/libsvn_fs_util-1.so.1.0.0
>>>>>>
>>>>>> I just tried deleting and rebuilding my python code and all worked
>>>>>> fine.
>>>>>>
>>>>>> -Steve
>>>>>>
>>>>>> On 09/29/2010 01:39 PM, [hidden email] wrote:
>>>>>>> Hi all,
>>>>>>>
>>>>>>> Get this error message when trying to run getbuildtest on
>>>>>>> Slicer3.6:
>>>>>>>
>>>>>>> panamint:swallace:1:31pm[96] ./Scripts/getbuildtest.tcl -t ""
>>>>>>> Sourcing
>>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>>>>>> Slicer3_HOME is
>>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>>>>>> making with make -j 4
>>>>>>> running: svn switch http://svn.slicer.org/Slicer3/trunk
>>>>>>> At revision 15105.
>>>>>>>
>>>>>>> running: sh ./Scripts/genlib.tcl
>>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>>>>>> -64
>>>>>>> Sourcing
>>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/slicer_variables.tcl
>>>>>>> Slicer3_HOME is
>>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3
>>>>>>> running: svn co http://svn.scipy.org/svn/numpy/branches/1.3.x numpy
>>>>>>> Checked out revision 8716.
>>>>>>>
>>>>>>> running:
>>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib/python-build/bin/python
>>>>>>> ./setup.py build --fcompiler=xxx
>>>>>>> svn: error while loading shared libraries: libsvn_fs_util-1.so.0:
>>>>>>> cannot
>>>>>>> open shared object file: No such file or directory
>>>>>>> Traceback (most recent call last):
>>>>>>>   File "./setup.py", line 104, in<module>
>>>>>>>     FULLVERSION += svn_version()
>>>>>>>   File "./setup.py", line 86, in svn_version
>>>>>>>     raise ValueError("Error while parsing svn version ?")
>>>>>>> ValueError: Error while parsing svn version ?
>>>>>>>
>>>>>>> child process exited abnormally
>>>>>>> 1
>>>>>>>     while executing
>>>>>>> "error $ret"
>>>>>>>     (procedure "runcmd" line 23)
>>>>>>>     invoked from within
>>>>>>> "runcmd $::Slicer3_LIB/python-build/bin/python ./setup.py build
>>>>>>> --fcompiler=xxx"
>>>>>>>     invoked from within
>>>>>>> "if {  [BuildThis $::NUMPY_TEST_FILE "python"]&&
>>>>>>> !$::USE_SYSTEM_PYTHON&&
>>>>>>> [string tolower $::USE_PYTHON] == "on" } {
>>>>>>>
>>>>>>>     set ::env(PYTHONHOME) $::Sli..."
>>>>>>>     (file "./Scripts/genlib.tcl" line 762)
>>>>>>>
>>>>>>> child process exited abnormally
>>>>>>> ERROR: failed to run getbuildtest: sh ./Scripts/genlib.tcl
>>>>>>> /autofs/space/birn_061/users/swallace/Slicer/slicer-source/Slicer3/../Slicer3-lib
>>>>>>> -64
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> I checkd out the code from  http://svn.slicer.org/Slicer3/trunk.
>>>>>>>
>>>>>>> Many thanks,
>>>>>>>
>>>>>>> Stuart
>>>>>>> _______________________________________________
>>>>>>> slicer-devel mailing list
>>>>>>> [hidden email]
>>>>>>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>>>>>>> To unsubscribe: send email to
>>>>>>> [hidden email] with unsubscribe as
>>>>>>> the
>>>>>>> subject
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>> _______________________________________________
>>>> slicer-devel mailing list
>>>> [hidden email]
>>>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>>>> To unsubscribe: send email to
>>>> [hidden email] with unsubscribe as the
>>>> subject
>>>
>>>
>>>
>>>
>>
>
>
>
>

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject