problem installing vmtk module on linux x86

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

problem installing vmtk module on linux x86

Davide Pasini
Hi all,
I'm trying to install Vmtk Module inside slicer.
I've followed this tutorial
(http://wiki.slicer.org/slicerWiki/index.php/Modules:VMTK_in_3D_Slicer_Tutorial:_Coronary_Artery_Centerline_Extraction) but when I try to start VMTKVesselEnhancement slicer returns this error: "VmtkSlicerModule not found! PLease install the VmtkSlicerModule extension to use this module!"
My slicer version is Slicer3-3.5-alpha-2010-02-14-linux-x86 and the
modules directory is "http://ext.slicer.org/ext/trunk/10201-linux-x86/"
What could be wrong?

Thanks

Davide Pasini

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: problem installing vmtk module on linux x86

Daniel Haehn
Hi Davide,

please try the following repository URL in the wizard:
http://ext.slicer.org/ext/trunk/11819-linux-x86_64/

Let me know if it works then.

Bye,
Daniel

On Mon, 2010-02-15 at 08:11 +0100, Davide Pasini wrote:

> Hi all,
> I'm trying to install Vmtk Module inside slicer.
> I've followed this tutorial
> (http://wiki.slicer.org/slicerWiki/index.php/Modules:VMTK_in_3D_Slicer_Tutorial:_Coronary_Artery_Centerline_Extraction) but when I try to start VMTKVesselEnhancement slicer returns this error: "VmtkSlicerModule not found! PLease install the VmtkSlicerModule extension to use this module!"
> My slicer version is Slicer3-3.5-alpha-2010-02-14-linux-x86 and the
> modules directory is "http://ext.slicer.org/ext/trunk/10201-linux-x86/"
> What could be wrong?
>
> Thanks
>
> Davide Pasini
>
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: problem installing vmtk module on linux x86

Daniel Haehn
In reply to this post by Davide Pasini
Hi Davide,

looks good! But this is wrong:
12133/VmtkSlicerModule/VmtkSlicerModule/...some *.so files

The VmtkSlicerModule is the only module which should sit in one directory,
like:
12133/VmtkSlicerModule/*.so

I am sorry for this issue but the extension build system is still under
development.

Let me know if it solves the issue. I include the slicer users list as a
recipient again.

Thx,
Daniel

On Mon, 15 Feb 2010 11:51:28 +0100, Davide Pasini <[hidden email]> wrote:

> Inside 12133 dire there are this tree:
> VMTKCenterlines/VMTKCenterlines/...some *.py files
> VMTKEasyLevelSetSegmentation/VMTKEasyLevelSetSegmentation/...some *.py
> files
> VMTKLevelSetSegmentation/VMTKLevelSetSegmentation/...some *.py files
> VmtkSlicerModule/VmtkSlicerModule/...some *.so files
> VMTKVesselEnhancement/VMTKVesselEnhancement/...some *.py files
>
> Davide
>
>
> On Mon, 2010-02-15 at 05:43 -0500, Daniel Haehn wrote:
>> You're right - its the slicer svn rev. not the one of the extensions.
>> Anyway, then what is inside 12133/?
>>
>> D.
>>
>> On Mon, 15 Feb 2010 11:37:22 +0100, Davide Pasini <[hidden email]>
> wrote:
>> > Hi again Daniel,
>> > I have not the /home/..../11819 directory. There is a 12133 dir but
> I'm
>> > sure to write the right address by hand and not with a copy/paste!
>> > I think Slicer uses always the default address and not
>> > http://ext.slicer.org/ext/trunk/11819-linux-x86_64/
>> > Thanks
>> >
>> > Davide
>> >
>> >
>> >
>> > On Mon, 2010-02-15 at 04:16 -0500, Daniel Haehn wrote:
>> >> Hey Davide,
>> >>
>> >> this is odd. Could you please double check if you installed
>> >> VmtkSlicerModule? Could you please also list the directories found at
>> >> /home/username/Slicer3User/11819/?
>> >>
>> >> Thanks,
>> >> Daniel
>> >>
>> >> On Mon, 15 Feb 2010 09:46:14 +0100, Davide Pasini <[hidden email]>
>> > wrote:
>> >> > Hi Daniel,
>> >> > Thanks for your answer but it doesn't work. The error is the same
>> >> > "VmtkSlicerModule not found! PLease install the VmtkSlicerModule
>> >> > extension to use this module!".
>> >> >
>> >> > Thanks
>> >> >
>> >> > Davide
>> >> >
>> >> > On Mon, 2010-02-15 at 08:34 +0100, Daniel Haehn wrote:
>> >> >> Hi Davide,
>> >> >>
>> >> >> please try the following repository URL in the wizard:
>> >> >> http://ext.slicer.org/ext/trunk/11819-linux-x86_64/
>> >> >>
>> >> >> Let me know if it works then.
>> >> >>
>> >> >> Bye,
>> >> >> Daniel
>> >> >>
>> >> >> On Mon, 2010-02-15 at 08:11 +0100, Davide Pasini wrote:
>> >> >> > Hi all,
>> >> >> > I'm trying to install Vmtk Module inside slicer.
>> >> >> > I've followed this tutorial
>> >> >> >
>> >> >
>> >>
>> >
>>
>
(http://wiki.slicer.org/slicerWiki/index.php/Modules:VMTK_in_3D_Slicer_Tutorial:_Coronary_Artery_Centerline_Extraction)

>> >> > but when I try to start VMTKVesselEnhancement slicer returns this
>> > error:
>> >> > "VmtkSlicerModule not found! PLease install the VmtkSlicerModule
>> >> extension
>> >> > to use this module!"
>> >> >> > My slicer version is Slicer3-3.5-alpha-2010-02-14-linux-x86 and
> the
>> >> >> > modules directory is
>> >> > "http://ext.slicer.org/ext/trunk/10201-linux-x86/"
>> >> >> > What could be wrong?
>> >> >> >
>> >> >> > Thanks
>> >> >> >
>> >> >> > Davide Pasini
>> >> >> >
>> >> >> > _______________________________________________
>> >> >> > slicer-users mailing list
>> >> >> > [hidden email]
>> >> >> > http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> >> >> > To unsubscribe: send email to
>> >> > [hidden email] with unsubscribe as
> the
>> >> > subject
>> >> >>
>> >>
>>

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: problem installing vmtk module on linux x86

Daniel Haehn
In reply to this post by Davide Pasini
Hi Davide,

ahh that is indeed the problem. The extensions are only compiled for 64bit.
There seems to be still an error with the general compilation of 32bit
extensions.. In particular the 64bit version of VmtkSlicerModule (the VMTK
libraries) can not be used on a 32bit platform.

If you use a self-compiled version of slicer, you can build your own 32bit
VmtkSlicerModule:
1. cd /Slicer3
2. Scripts/extend.tcl Extensions/VmtkSlicerModule.s3ext

Then use the extension wizard without changing the repository url (your SVN
rev. must be in the url) to install this extension.

The VMTK* (python) modules you already installed should work also with
32bit.

Bye,
Daniel

On Mon, 15 Feb 2010 12:17:19 +0100, Davide Pasini <[hidden email]> wrote:

> Sorry, the VmtkSlicerModule is in right dir: 12133/VmtkSlicerModule/*.so
> files.
>
> Do you know a working Slicer version with Vmtk?
> Another question: is the reporitory
> http://ext.slicer.org/ext/trunk/11819-linux-x86_64/  only for 64bit
> systems or for 32bit systems too?
>
> I'm working on a 32bit system.
> Thanks
> Davide
>
>
> On Mon, 2010-02-15 at 06:06 -0500, Daniel Haehn wrote:
>> Hi Davide,
>>
>> looks good! But this is wrong:
>> 12133/VmtkSlicerModule/VmtkSlicerModule/...some *.so files
>>
>> The VmtkSlicerModule is the only module which should sit in one
> directory,
>> like:
>> 12133/VmtkSlicerModule/*.so
>>
>> I am sorry for this issue but the extension build system is still under
>> development.
>>
>> Let me know if it solves the issue. I include the slicer users list as a
>> recipient again.
>>
>> Thx,
>> Daniel
>>
>> On Mon, 15 Feb 2010 11:51:28 +0100, Davide Pasini <[hidden email]>
> wrote:
>> > Inside 12133 dire there are this tree:
>> > VMTKCenterlines/VMTKCenterlines/...some *.py files
>> > VMTKEasyLevelSetSegmentation/VMTKEasyLevelSetSegmentation/...some *.py
>> > files
>> > VMTKLevelSetSegmentation/VMTKLevelSetSegmentation/...some *.py files
>> > VmtkSlicerModule/VmtkSlicerModule/...some *.so files
>> > VMTKVesselEnhancement/VMTKVesselEnhancement/...some *.py files
>> >
>> > Davide
>> >
>> >
>> > On Mon, 2010-02-15 at 05:43 -0500, Daniel Haehn wrote:
>> >> You're right - its the slicer svn rev. not the one of the extensions.
>> >> Anyway, then what is inside 12133/?
>> >>
>> >> D.
>> >>
>> >> On Mon, 15 Feb 2010 11:37:22 +0100, Davide Pasini <[hidden email]>
>> > wrote:
>> >> > Hi again Daniel,
>> >> > I have not the /home/..../11819 directory. There is a 12133 dir but
>> > I'm
>> >> > sure to write the right address by hand and not with a copy/paste!
>> >> > I think Slicer uses always the default address and not
>> >> > http://ext.slicer.org/ext/trunk/11819-linux-x86_64/
>> >> > Thanks
>> >> >
>> >> > Davide
>> >> >
>> >> >
>> >> >
>> >> > On Mon, 2010-02-15 at 04:16 -0500, Daniel Haehn wrote:
>> >> >> Hey Davide,
>> >> >>
>> >> >> this is odd. Could you please double check if you installed
>> >> >> VmtkSlicerModule? Could you please also list the directories found
> at
>> >> >> /home/username/Slicer3User/11819/?
>> >> >>
>> >> >> Thanks,
>> >> >> Daniel
>> >> >>
>> >> >> On Mon, 15 Feb 2010 09:46:14 +0100, Davide Pasini
> <[hidden email]>
>> >> > wrote:
>> >> >> > Hi Daniel,
>> >> >> > Thanks for your answer but it doesn't work. The error is the
> same
>> >> >> > "VmtkSlicerModule not found! PLease install the VmtkSlicerModule
>> >> >> > extension to use this module!".
>> >> >> >
>> >> >> > Thanks
>> >> >> >
>> >> >> > Davide
>> >> >> >
>> >> >> > On Mon, 2010-02-15 at 08:34 +0100, Daniel Haehn wrote:
>> >> >> >> Hi Davide,
>> >> >> >>
>> >> >> >> please try the following repository URL in the wizard:
>> >> >> >> http://ext.slicer.org/ext/trunk/11819-linux-x86_64/
>> >> >> >>
>> >> >> >> Let me know if it works then.
>> >> >> >>
>> >> >> >> Bye,
>> >> >> >> Daniel
>> >> >> >>
>> >> >> >> On Mon, 2010-02-15 at 08:11 +0100, Davide Pasini wrote:
>> >> >> >> > Hi all,
>> >> >> >> > I'm trying to install Vmtk Module inside slicer.
>> >> >> >> > I've followed this tutorial
>> >> >> >> >
>> >> >> >
>> >> >>
>> >> >
>> >>
>> >
>>
>
(http://wiki.slicer.org/slicerWiki/index.php/Modules:VMTK_in_3D_Slicer_Tutorial:_Coronary_Artery_Centerline_Extraction)

>> >> >> > but when I try to start VMTKVesselEnhancement slicer returns
> this
>> >> > error:
>> >> >> > "VmtkSlicerModule not found! PLease install the VmtkSlicerModule
>> >> >> extension
>> >> >> > to use this module!"
>> >> >> >> > My slicer version is Slicer3-3.5-alpha-2010-02-14-linux-x86
> and
>> > the
>> >> >> >> > modules directory is
>> >> >> > "http://ext.slicer.org/ext/trunk/10201-linux-x86/"
>> >> >> >> > What could be wrong?
>> >> >> >> >
>> >> >> >> > Thanks
>> >> >> >> >
>> >> >> >> > Davide Pasini
>> >> >> >> >
>> >> >> >> > _______________________________________________
>> >> >> >> > slicer-users mailing list
>> >> >> >> > [hidden email]
>> >> >> >> > http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>> >> >> >> > To unsubscribe: send email to
>> >> >> > [hidden email] with unsubscribe
> as
>> > the
>> >> >> > subject
>> >> >> >>
>> >> >>
>> >>
>>

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: problem installing vmtk module on linux x86

Davide Pasini
thanks a lot.
I'm using a pre-compiled version of slicer3.
Can you tell me the right way (or a link) in order to build a Slicer3d
version for my 32bit platform and a vmtk extension?

thanks
Davide

On Mon, 2010-02-15 at 06:38 -0500, Daniel Haehn wrote:

> Hi Davide,
>
> ahh that is indeed the problem. The extensions are only compiled for 64bit.
> There seems to be still an error with the general compilation of 32bit
> extensions.. In particular the 64bit version of VmtkSlicerModule (the VMTK
> libraries) can not be used on a 32bit platform.
>
> If you use a self-compiled version of slicer, you can build your own 32bit
> VmtkSlicerModule:
> 1. cd /Slicer3
> 2. Scripts/extend.tcl Extensions/VmtkSlicerModule.s3ext
>
> Then use the extension wizard without changing the repository url (your SVN
> rev. must be in the url) to install this extension.
>
> The VMTK* (python) modules you already installed should work also with
> 32bit.
>
> Bye,
> Daniel
>
> On Mon, 15 Feb 2010 12:17:19 +0100, Davide Pasini <[hidden email]> wrote:
> > Sorry, the VmtkSlicerModule is in right dir: 12133/VmtkSlicerModule/*.so
> > files.
> >
> > Do you know a working Slicer version with Vmtk?
> > Another question: is the reporitory
> > http://ext.slicer.org/ext/trunk/11819-linux-x86_64/  only for 64bit
> > systems or for 32bit systems too?
> >
> > I'm working on a 32bit system.
> > Thanks
> > Davide
> >
> >
> > On Mon, 2010-02-15 at 06:06 -0500, Daniel Haehn wrote:
> >> Hi Davide,
> >>
> >> looks good! But this is wrong:
> >> 12133/VmtkSlicerModule/VmtkSlicerModule/...some *.so files
> >>
> >> The VmtkSlicerModule is the only module which should sit in one
> > directory,
> >> like:
> >> 12133/VmtkSlicerModule/*.so
> >>
> >> I am sorry for this issue but the extension build system is still under
> >> development.
> >>
> >> Let me know if it solves the issue. I include the slicer users list as a
> >> recipient again.
> >>
> >> Thx,
> >> Daniel
> >>
> >> On Mon, 15 Feb 2010 11:51:28 +0100, Davide Pasini <[hidden email]>
> > wrote:
> >> > Inside 12133 dire there are this tree:
> >> > VMTKCenterlines/VMTKCenterlines/...some *.py files
> >> > VMTKEasyLevelSetSegmentation/VMTKEasyLevelSetSegmentation/...some *.py
> >> > files
> >> > VMTKLevelSetSegmentation/VMTKLevelSetSegmentation/...some *.py files
> >> > VmtkSlicerModule/VmtkSlicerModule/...some *.so files
> >> > VMTKVesselEnhancement/VMTKVesselEnhancement/...some *.py files
> >> >
> >> > Davide
> >> >
> >> >
> >> > On Mon, 2010-02-15 at 05:43 -0500, Daniel Haehn wrote:
> >> >> You're right - its the slicer svn rev. not the one of the extensions.
> >> >> Anyway, then what is inside 12133/?
> >> >>
> >> >> D.
> >> >>
> >> >> On Mon, 15 Feb 2010 11:37:22 +0100, Davide Pasini <[hidden email]>
> >> > wrote:
> >> >> > Hi again Daniel,
> >> >> > I have not the /home/..../11819 directory. There is a 12133 dir but
> >> > I'm
> >> >> > sure to write the right address by hand and not with a copy/paste!
> >> >> > I think Slicer uses always the default address and not
> >> >> > http://ext.slicer.org/ext/trunk/11819-linux-x86_64/
> >> >> > Thanks
> >> >> >
> >> >> > Davide
> >> >> >
> >> >> >
> >> >> >
> >> >> > On Mon, 2010-02-15 at 04:16 -0500, Daniel Haehn wrote:
> >> >> >> Hey Davide,
> >> >> >>
> >> >> >> this is odd. Could you please double check if you installed
> >> >> >> VmtkSlicerModule? Could you please also list the directories found
> > at
> >> >> >> /home/username/Slicer3User/11819/?
> >> >> >>
> >> >> >> Thanks,
> >> >> >> Daniel
> >> >> >>
> >> >> >> On Mon, 15 Feb 2010 09:46:14 +0100, Davide Pasini
> > <[hidden email]>
> >> >> > wrote:
> >> >> >> > Hi Daniel,
> >> >> >> > Thanks for your answer but it doesn't work. The error is the
> > same
> >> >> >> > "VmtkSlicerModule not found! PLease install the VmtkSlicerModule
> >> >> >> > extension to use this module!".
> >> >> >> >
> >> >> >> > Thanks
> >> >> >> >
> >> >> >> > Davide
> >> >> >> >
> >> >> >> > On Mon, 2010-02-15 at 08:34 +0100, Daniel Haehn wrote:
> >> >> >> >> Hi Davide,
> >> >> >> >>
> >> >> >> >> please try the following repository URL in the wizard:
> >> >> >> >> http://ext.slicer.org/ext/trunk/11819-linux-x86_64/
> >> >> >> >>
> >> >> >> >> Let me know if it works then.
> >> >> >> >>
> >> >> >> >> Bye,
> >> >> >> >> Daniel
> >> >> >> >>
> >> >> >> >> On Mon, 2010-02-15 at 08:11 +0100, Davide Pasini wrote:
> >> >> >> >> > Hi all,
> >> >> >> >> > I'm trying to install Vmtk Module inside slicer.
> >> >> >> >> > I've followed this tutorial
> >> >> >> >> >
> >> >> >> >
> >> >> >>
> >> >> >
> >> >>
> >> >
> >>
> >
> (http://wiki.slicer.org/slicerWiki/index.php/Modules:VMTK_in_3D_Slicer_Tutorial:_Coronary_Artery_Centerline_Extraction)
> >> >> >> > but when I try to start VMTKVesselEnhancement slicer returns
> > this
> >> >> > error:
> >> >> >> > "VmtkSlicerModule not found! PLease install the VmtkSlicerModule
> >> >> >> extension
> >> >> >> > to use this module!"
> >> >> >> >> > My slicer version is Slicer3-3.5-alpha-2010-02-14-linux-x86
> > and
> >> > the
> >> >> >> >> > modules directory is
> >> >> >> > "http://ext.slicer.org/ext/trunk/10201-linux-x86/"
> >> >> >> >> > What could be wrong?
> >> >> >> >> >
> >> >> >> >> > Thanks
> >> >> >> >> >
> >> >> >> >> > Davide Pasini
> >> >> >> >> >
> >> >> >> >> > _______________________________________________
> >> >> >> >> > slicer-users mailing list
> >> >> >> >> > [hidden email]
> >> >> >> >> > http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> >> >> >> >> > To unsubscribe: send email to
> >> >> >> > [hidden email] with unsubscribe
> > as
> >> > the
> >> >> >> > subject
> >> >> >> >>
> >> >> >>
> >> >>
> >>
>


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject