problem with slicer build

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

problem with slicer build

Harish Doddi
Hi,

I just downloaded the latest slicer  source code and trying to build it on CMake 2.6 compiler. All the libraries are built in Slicer-lib directory but I get this error at the end of build. Could someone please help?

At revision 12367.

running: sh ./Scripts/genlib.tcl /home/spal/Slicer/Slicer3/../Slicer3-lib -32 --test-type Experimental
Sourcing /home/spal/Slicer/Slicer3/slicer_variables.tcl
Slicer3_HOME is /home/spal/Slicer/Slicer3
All packages compiled.

running: /home/spal/Slicer/Slicer3/../Slicer3-lib/CMake-build/bin/cmake {-GUnix Makefiles} {-DMAKECOMMAND:STRING=make -j 4} -DCMAKE_CXX_COMPILER:STRING=/usr/bin/g++ -DCMAKE_CXX_COMPILER_FULLPATH:FILEPATH=/usr/bin/g++ -DITK_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/Insight-build -DKWWidgets_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/KWWidgets-build -DOpenCV_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/OpenCV-build -DTeem_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/teem-build -DOpenIGTLink_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/OpenIGTLink-build -DBatchMake_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/BatchMake-build -DSlicer3_USE_BatchMake=ON -DINCR_TCL_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/tcl-build/lib/lib/libitcl3.2.so -DINCR_TK_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/tcl-build/lib/lib/libitk3.2.so -DSlicer3_USE_PYTHON=ON -DSlicer3_USE_SYSTEM_PYTHON=OFF -DSlicer3_USE_NUMPY=ON -DSlicer3_USE_OPENIGTLINK=ON -DSlicer3_USE_OPENCV=OFF -DPYTHON_INCLUDE_PATH:PATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/python-build/include/python2.6 -DPYTHON_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/python-build/lib/libpython2.6.so -DSandBox_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/NAMICSandBox -DCMAKE_BUILD_TYPE=Debug -DSlicer3_VERSION_PATCH:STRING=2010-03-16 -DCPACK_GENERATOR:STRING=TGZ -DCPACK_PACKAGE_FILE_NAME:STRING=Slicer3-3.5-alpha-2010-03-16-linux-x86 -DCPACK_RPM_SPEC_MORE_DEFINE= -DSLICERLIBCURL_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/cmcurl-build -DCMAKE_VERBOSE_MAKEFILE:BOOL=OFF -DLAUNCHER_REPORT_VTK_ERRORS=OFF /home/spal/Slicer/Slicer3
CMake Error at CMakeLists.txt:6 (CMAKE_POLICY):
  Policy "CMP0012" is not known to this version of CMake.


-- Slicer3_BUILD:linux-x86
-- Specify CUDA_INSTALL_PREFIX
-- Configuring incomplete, errors occurred!

child process exited abnormally
1
    while executing
"error $ret"
    (procedure "runcmd" line 23)
    invoked from within
"runcmd $::CMAKE \
        -G$::GENERATOR \
        -DMAKECOMMAND:STRING=$::MAKE \
        -DCMAKE_CXX_COMPILER:STRING=$COMPILER_PATH/$COMPILER \
     ..."
    (file "./Slicer3/Scripts/getbuildtest.tcl" line 495)


Thanks,
Harish

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: problem with slicer build

Andrey Fedorov
Harish,

I think Slicer trunk switched to CMake 2.8, and you are using 2.6. To
update cmake, you can run getbuildtest with "--update" flag, or, to be
safe, you can manually remove old cmake "rm -rf Slicer3-lib/CMake*"

Also, it looks like you have Python turned on. I am not sure how
stable is Python build out of the box, but if you have problems with
this, you can set USE_PYTHON=OFF in slicer_variables.tcl.

AF


On Tue, Mar 16, 2010 at 17:49, Harish Doddi <[hidden email]> wrote:

> Hi,
>
> I just downloaded the latest slicer  source code and trying to build it on
> CMake 2.6 compiler. All the libraries are built in Slicer-lib directory but
> I get this error at the end of build. Could someone please help?
>
> At revision 12367.
>
> running: sh ./Scripts/genlib.tcl /home/spal/Slicer/Slicer3/../Slicer3-lib
> -32 --test-type Experimental
> Sourcing /home/spal/Slicer/Slicer3/slicer_variables.tcl
> Slicer3_HOME is /home/spal/Slicer/Slicer3
> All packages compiled.
>
> running: /home/spal/Slicer/Slicer3/../Slicer3-lib/CMake-build/bin/cmake
> {-GUnix Makefiles} {-DMAKECOMMAND:STRING=make -j 4}
> -DCMAKE_CXX_COMPILER:STRING=/usr/bin/g++
> -DCMAKE_CXX_COMPILER_FULLPATH:FILEPATH=/usr/bin/g++
> -DITK_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/Insight-build
> -DKWWidgets_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/KWWidgets-build
> -DOpenCV_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/OpenCV-build
> -DTeem_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/teem-build
> -DOpenIGTLink_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/OpenIGTLink-build
> -DBatchMake_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/BatchMake-build
> -DSlicer3_USE_BatchMake=ON
> -DINCR_TCL_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/tcl-build/lib/lib/libitcl3.2.so
> -DINCR_TK_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/tcl-build/lib/lib/libitk3.2.so
> -DSlicer3_USE_PYTHON=ON -DSlicer3_USE_SYSTEM_PYTHON=OFF
> -DSlicer3_USE_NUMPY=ON -DSlicer3_USE_OPENIGTLINK=ON -DSlicer3_USE_OPENCV=OFF
> -DPYTHON_INCLUDE_PATH:PATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/python-build/include/python2.6
> -DPYTHON_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/python-build/lib/libpython2.6.so
> -DSandBox_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/NAMICSandBox
> -DCMAKE_BUILD_TYPE=Debug -DSlicer3_VERSION_PATCH:STRING=2010-03-16
> -DCPACK_GENERATOR:STRING=TGZ
> -DCPACK_PACKAGE_FILE_NAME:STRING=Slicer3-3.5-alpha-2010-03-16-linux-x86
> -DCPACK_RPM_SPEC_MORE_DEFINE=
> -DSLICERLIBCURL_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/cmcurl-build
> -DCMAKE_VERBOSE_MAKEFILE:BOOL=OFF -DLAUNCHER_REPORT_VTK_ERRORS=OFF
> /home/spal/Slicer/Slicer3
> CMake Error at CMakeLists.txt:6 (CMAKE_POLICY):
>   Policy "CMP0012" is not known to this version of CMake.
>
>
> -- Slicer3_BUILD:linux-x86
> -- Specify CUDA_INSTALL_PREFIX
> -- Configuring incomplete, errors occurred!
>
> child process exited abnormally
> 1
>     while executing
> "error $ret"
>     (procedure "runcmd" line 23)
>     invoked from within
> "runcmd $::CMAKE \
>         -G$::GENERATOR \
>         -DMAKECOMMAND:STRING=$::MAKE \
>         -DCMAKE_CXX_COMPILER:STRING=$COMPILER_PATH/$COMPILER \
>      ..."
>     (file "./Slicer3/Scripts/getbuildtest.tcl" line 495)
>
>
> Thanks,
> Harish
>
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email]
> with unsubscribe as the subject
>
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: problem with slicer build

Harish Doddi
hi Andriy,

I did make the changes you suggested. Now I build the slicer successfully, but I do get the attached picture error, whenever I am starting Slicer. Could someone please guide me on this?


Thanks,
harish

On Tue, Mar 16, 2010 at 4:17 PM, Andriy Fedorov <[hidden email]> wrote:
Harish,

I think Slicer trunk switched to CMake 2.8, and you are using 2.6. To
update cmake, you can run getbuildtest with "--update" flag, or, to be
safe, you can manually remove old cmake "rm -rf Slicer3-lib/CMake*"

Also, it looks like you have Python turned on. I am not sure how
stable is Python build out of the box, but if you have problems with
this, you can set USE_PYTHON=OFF in slicer_variables.tcl.

AF


On Tue, Mar 16, 2010 at 17:49, Harish Doddi <[hidden email]> wrote:
> Hi,
>
> I just downloaded the latest slicer  source code and trying to build it on
> CMake 2.6 compiler. All the libraries are built in Slicer-lib directory but
> I get this error at the end of build. Could someone please help?
>
> At revision 12367.
>
> running: sh ./Scripts/genlib.tcl /home/spal/Slicer/Slicer3/../Slicer3-lib
> -32 --test-type Experimental
> Sourcing /home/spal/Slicer/Slicer3/slicer_variables.tcl
> Slicer3_HOME is /home/spal/Slicer/Slicer3
> All packages compiled.
>
> running: /home/spal/Slicer/Slicer3/../Slicer3-lib/CMake-build/bin/cmake
> {-GUnix Makefiles} {-DMAKECOMMAND:STRING=make -j 4}
> -DCMAKE_CXX_COMPILER:STRING=/usr/bin/g++
> -DCMAKE_CXX_COMPILER_FULLPATH:FILEPATH=/usr/bin/g++
> -DITK_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/Insight-build
> -DKWWidgets_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/KWWidgets-build
> -DOpenCV_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/OpenCV-build
> -DTeem_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/teem-build
> -DOpenIGTLink_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/OpenIGTLink-build
> -DBatchMake_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/BatchMake-build
> -DSlicer3_USE_BatchMake=ON
> -DINCR_TCL_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/tcl-build/lib/lib/libitcl3.2.so
> -DINCR_TK_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/tcl-build/lib/lib/libitk3.2.so
> -DSlicer3_USE_PYTHON=ON -DSlicer3_USE_SYSTEM_PYTHON=OFF
> -DSlicer3_USE_NUMPY=ON -DSlicer3_USE_OPENIGTLINK=ON -DSlicer3_USE_OPENCV=OFF
> -DPYTHON_INCLUDE_PATH:PATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/python-build/include/python2.6
> -DPYTHON_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/python-build/lib/libpython2.6.so
> -DSandBox_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/NAMICSandBox
> -DCMAKE_BUILD_TYPE=Debug -DSlicer3_VERSION_PATCH:STRING=2010-03-16
> -DCPACK_GENERATOR:STRING=TGZ
> -DCPACK_PACKAGE_FILE_NAME:STRING=Slicer3-3.5-alpha-2010-03-16-linux-x86
> -DCPACK_RPM_SPEC_MORE_DEFINE=
> -DSLICERLIBCURL_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/cmcurl-build
> -DCMAKE_VERBOSE_MAKEFILE:BOOL=OFF -DLAUNCHER_REPORT_VTK_ERRORS=OFF
> /home/spal/Slicer/Slicer3
> CMake Error at CMakeLists.txt:6 (CMAKE_POLICY):
>   Policy "CMP0012" is not known to this version of CMake.
>
>
> -- Slicer3_BUILD:linux-x86
> -- Specify CUDA_INSTALL_PREFIX
> -- Configuring incomplete, errors occurred!
>
> child process exited abnormally
> 1
>     while executing
> "error $ret"
>     (procedure "runcmd" line 23)
>     invoked from within
> "runcmd $::CMAKE \
>         -G$::GENERATOR \
>         -DMAKECOMMAND:STRING=$::MAKE \
>         -DCMAKE_CXX_COMPILER:STRING=$COMPILER_PATH/$COMPILER \
>      ..."
>     (file "./Slicer3/Scripts/getbuildtest.tcl" line 495)
>
>
> Thanks,
> Harish
>
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email]
> with unsubscribe as the subject
>


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

SlicerError.tiff (764K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: problem with slicer build

pieper
Administrator
Hi Harish -

There's still something wrong with the build there (the bin/Slicer3-real
executable is missing, so the build failed).

If this is an older build directory you might be better off to do a
fresh build (there's been a lot of change lately).  You could either
start from scratch in a new directory or use the --clean option to
getbuildtest (to delete Slicer3-lib and Slicer3-build).

Best,
Steve

On M/16/10 8:38 PM, Harish Doddi wrote:

> hi Andriy,
>
> I did make the changes you suggested. Now I build the slicer
> successfully, but I do get the attached picture error, whenever I am
> starting Slicer. Could someone please guide me on this?
>
>
> Thanks,
> harish
>
> On Tue, Mar 16, 2010 at 4:17 PM, Andriy Fedorov <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Harish,
>
>     I think Slicer trunk switched to CMake 2.8, and you are using 2.6. To
>     update cmake, you can run getbuildtest with "--update" flag, or, to be
>     safe, you can manually remove old cmake "rm -rf Slicer3-lib/CMake*"
>
>     Also, it looks like you have Python turned on. I am not sure how
>     stable is Python build out of the box, but if you have problems with
>     this, you can set USE_PYTHON=OFF in slicer_variables.tcl.
>
>     AF
>
>
>     On Tue, Mar 16, 2010 at 17:49, Harish Doddi <[hidden email]
>     <mailto:[hidden email]>> wrote:
>      > Hi,
>      >
>      > I just downloaded the latest slicer  source code and trying to
>     build it on
>      > CMake 2.6 compiler. All the libraries are built in Slicer-lib
>     directory but
>      > I get this error at the end of build. Could someone please help?
>      >
>      > At revision 12367.
>      >
>      > running: sh ./Scripts/genlib.tcl
>     /home/spal/Slicer/Slicer3/../Slicer3-lib
>      > -32 --test-type Experimental
>      > Sourcing /home/spal/Slicer/Slicer3/slicer_variables.tcl
>      > Slicer3_HOME is /home/spal/Slicer/Slicer3
>      > All packages compiled.
>      >
>      > running:
>     /home/spal/Slicer/Slicer3/../Slicer3-lib/CMake-build/bin/cmake
>      > {-GUnix Makefiles} {-DMAKECOMMAND:STRING=make -j 4}
>      > -DCMAKE_CXX_COMPILER:STRING=/usr/bin/g++
>      > -DCMAKE_CXX_COMPILER_FULLPATH:FILEPATH=/usr/bin/g++
>      >
>     -DITK_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/Insight-build
>      >
>     -DKWWidgets_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/KWWidgets-build
>      >
>     -DOpenCV_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/OpenCV-build
>      >
>     -DTeem_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/teem-build
>      >
>     -DOpenIGTLink_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/OpenIGTLink-build
>      >
>     -DBatchMake_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/BatchMake-build
>      > -DSlicer3_USE_BatchMake=ON
>      >
>     -DINCR_TCL_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/tcl-build/lib/lib/libitcl3.2.so
>     <http://libitcl3.2.so>
>      >
>     -DINCR_TK_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/tcl-build/lib/lib/libitk3.2.so
>     <http://libitk3.2.so>
>      > -DSlicer3_USE_PYTHON=ON -DSlicer3_USE_SYSTEM_PYTHON=OFF
>      > -DSlicer3_USE_NUMPY=ON -DSlicer3_USE_OPENIGTLINK=ON
>     -DSlicer3_USE_OPENCV=OFF
>      >
>     -DPYTHON_INCLUDE_PATH:PATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/python-build/include/python2.6
>      >
>     -DPYTHON_LIBRARY:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/python-build/lib/libpython2.6.so
>     <http://libpython2.6.so>
>      >
>     -DSandBox_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/NAMICSandBox
>      > -DCMAKE_BUILD_TYPE=Debug -DSlicer3_VERSION_PATCH:STRING=2010-03-16
>      > -DCPACK_GENERATOR:STRING=TGZ
>      >
>     -DCPACK_PACKAGE_FILE_NAME:STRING=Slicer3-3.5-alpha-2010-03-16-linux-x86
>      > -DCPACK_RPM_SPEC_MORE_DEFINE=
>      >
>     -DSLICERLIBCURL_DIR:FILEPATH=/home/spal/Slicer/Slicer3/../Slicer3-lib/cmcurl-build
>      > -DCMAKE_VERBOSE_MAKEFILE:BOOL=OFF -DLAUNCHER_REPORT_VTK_ERRORS=OFF
>      > /home/spal/Slicer/Slicer3
>      > CMake Error at CMakeLists.txt:6 (CMAKE_POLICY):
>      >   Policy "CMP0012" is not known to this version of CMake.
>      >
>      >
>      > -- Slicer3_BUILD:linux-x86
>      > -- Specify CUDA_INSTALL_PREFIX
>      > -- Configuring incomplete, errors occurred!
>      >
>      > child process exited abnormally
>      > 1
>      >     while executing
>      > "error $ret"
>      >     (procedure "runcmd" line 23)
>      >     invoked from within
>      > "runcmd $::CMAKE \
>      >         -G$::GENERATOR \
>      >         -DMAKECOMMAND:STRING=$::MAKE \
>      >         -DCMAKE_CXX_COMPILER:STRING=$COMPILER_PATH/$COMPILER \
>      >      ..."
>      >     (file "./Slicer3/Scripts/getbuildtest.tcl" line 495)
>      >
>      >
>      > Thanks,
>      > Harish
>      >
>      > _______________________________________________
>      > slicer-users mailing list
>      > [hidden email] <mailto:[hidden email]>
>      > http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
>      > To unsubscribe: send email to
>     [hidden email]
>     <mailto:[hidden email]>
>      > with unsubscribe as the subject
>      >
>
>
>
>
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject