vmtkslicer module is not recognized

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

vmtkslicer module is not recognized

Gary Doctors
I am a PhD student working on modelling cerebral blood flow using
Lattice-Boltzmann methods.

I installed Slicer 3.4.1 today by directly downloading the executable
files for linux-x86_84.  I installed the modules
VMTKEasyLevelSetSegmentation, VMTKLevelSetSegmentation and
VmtkSlicerModule using the extension manager.  I restarted Slicer.  The
first 2 modules appear in my list of modules, but the VmtkSlicerModule
does not, so something is wrong with the software.

I need this module for the tutorial
"VMTKLevelSetSegmentationAneurysmTutorial" which I tried today.  When I
used the DICOM file, then tried to use the LevelSetSegmentation module as
instructed in the tutorial, I got a message saying "please install
VmtkSlicerModule"

Please could someone help me with this.

Thank you,
Gary Doctors


_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: vmtkslicer module is not recognized

swallace
Hi Gary,

Try using the 3.5 version of Slicer, and let us know if it still gives you
this error. Thanks-

Stuart Wallace

> I am a PhD student working on modelling cerebral blood flow using
> Lattice-Boltzmann methods.
>
> I installed Slicer 3.4.1 today by directly downloading the executable
> files for linux-x86_84.  I installed the modules
> VMTKEasyLevelSetSegmentation, VMTKLevelSetSegmentation and
> VmtkSlicerModule using the extension manager.  I restarted Slicer.  The
> first 2 modules appear in my list of modules, but the VmtkSlicerModule
> does not, so something is wrong with the software.
>
> I need this module for the tutorial
> "VMTKLevelSetSegmentationAneurysmTutorial" which I tried today.  When I
> used the DICOM file, then tried to use the LevelSetSegmentation module as
> instructed in the tutorial, I got a message saying "please install
> VmtkSlicerModule"
>
> Please could someone help me with this.
>
> Thank you,
> Gary Doctors
>
>
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to
> [hidden email] with unsubscribe as the
> subject
>
>
>

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: vmtkslicer module is not recognized

Daniel Haehn
In reply to this post by Gary Doctors
Hi Gary,

thank you for your interest in VMTK in 3D Slicer!

Sorry, the modules only work with Slicer 3.5 because of recent changes
to the API in connection with multiple cameras.

And VmtkSlicerModule is never visible in the list of modules because it
is an "invisible" module just providing the VMTK libraries.

BTW: VMTK in 3D Slicer now can compute centerlines, check it out :)
http://wiki.slicer.org/slicerWiki/index.php/Modules:VMTK_in_3D_Slicer_Tutorial:_Coronary_Artery_Centerline_Extraction

Bye,
Daniel

On Fri, 2009-12-18 at 17:42 +0000, Gary Doctors wrote:

> I am a PhD student working on modelling cerebral blood flow using
> Lattice-Boltzmann methods.
>
> I installed Slicer 3.4.1 today by directly downloading the executable
> files for linux-x86_84.  I installed the modules
> VMTKEasyLevelSetSegmentation, VMTKLevelSetSegmentation and
> VmtkSlicerModule using the extension manager.  I restarted Slicer.  The
> first 2 modules appear in my list of modules, but the VmtkSlicerModule
> does not, so something is wrong with the software.
>
> I need this module for the tutorial
> "VMTKLevelSetSegmentationAneurysmTutorial" which I tried today.  When I
> used the DICOM file, then tried to use the LevelSetSegmentation module as
> instructed in the tutorial, I got a message saying "please install
> VmtkSlicerModule"
>
> Please could someone help me with this.
>
> Thank you,
> Gary Doctors
>
>
> _______________________________________________
> slicer-users mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject

_______________________________________________
slicer-users mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-users
To unsubscribe: send email to [hidden email] with unsubscribe as the subject